Gnome Software and 3rd Party Repositories

So I know that there are a few solutions to this problem that have already come up here, but by default Gnome Software will not display software from 3rd party repositories enabled through the application itself. I have submitted a bug for this, but are there any chances of it ever being resolved? I know Fedora is a very strict FOSS distro, but if why have the repos in a GUI interface if you cannot install software from them in the GUI?

Edit: Wrong bug link!

Hello @cheeseeboi, welcome to Fedora. Please take a look at the informative posts in #start-here if you’ve not yet had a chance to do so.

You’ve misunderstood the other post. Gnome software is not a front end for DNF—it is not designed to be so. It does not show all packages that DNF does—even from the Fedora repositories. It focuses mostly on GUI tools only.

Here is how DNF/packagekit works:

  • all packages in the Fedora repositories are listed in the repository metadata
  • when you run DNF, it downloads this metadata and does what it can.

Here is how Gnome-software works

  • GUI packages in repositories include a “desktop” file, or they include an “appdata” file.
  • the gnome-software maintainer generates “appstream” data from these files regularly and packages them in the appstream-data package.
  • Gnome software uses this appstream data to list software and work with them.
  • it does not look at the same repodata that DNF does.

So, like the Fedora repositories provide the appstream-data for Gnome Software to use, all the repositories you want to use (RPMFusion or others) also have to provide appstream-data for their packages. RPMFusion provides them in the rpmfusion-free-appstream-data and rpmfusion-nonfree-appstream-data packages.

If you want a GUI that has access to all packages like DNF does, you need to use dnfdragora. It is designed to be a front-end for DNF. On the other hand, Gnome-Software allows you to work with Flatpaks, but dnfdragora does not.

I hope that clarifies it. This is not a bug—it is the design. Gnome Software is meant for general end-users who tend to use GUI tools and want to be able to work with an app store like tool. Advanced users that want to access all the packages from the repositories must use DNF or dnfdragora (or packagekit).

1 Like

Thanks for replying, but you might not understand what I mean. I enabled these repositories through the “Software Repositories” dialog, which includes apps like Chrome and Steam, but they do not show up when searching for them. It’s one thing to not support RPMFusion if someone manually adds it, but it’s another thing when this feature is essentially useless without using the command line after enabling it!

Ah, right. Then you’re seeing a different issue. Did you update the metadata (in the “updates” tab, click the “reload” button in the top left hand corner)?

I do see Chrome in my gnome-software here, for example:

Steam is provided by RPMFusion as the third party repository. However, since Steam only has an i686 version, it currently cannot be installed using Gnome Software on x86_64 systems. Are you on an x86_64 system by any chance? If yes, you may be hitting this bug:

Steam is available on Flathub as a Flatpak now. I think that’s what most folks use. Could you give that a try?

1 Like

Hmm, I just tried installing a clean 64-bit Fedora 31 system in a vm, fully update it, then enable the third-party repositories. It took some time (and a reboot that was probably not necessary), but all available third-party apps (Steam, NVIDIA Drivers, Chrome, PyCharm) eventually showed up. I tried installing Steam and everything worked fine.

1 Like

Welcome to the forum @AsciiWolf! Thanks for taking a look.

Ah, even Steam? Maybe my metadata didn’t quite update fully then. :thinking:

(Just confirming: this isn’t Steam from Flathub, is it? That shows up on my Gnome-Software too.)

It wasn’t Steam from Flathub. Yeah, the metadata were slow to update for me as well. I enabled third-party repos, waited 10 minutes, tried to find Steam in GS and there was nothing. Rebooted the machine, tried to find Steam again, nothing. Closed the GS window, waited another 10 minutes, tried searching for Steam again and it was finally here. Tried installing it and everything was ok. :slight_smile:

1 Like

I’m still not seeing it :laughing: but I’ve not restarted etc. yet.

Okay, so I forgot to clarify that I am in a VM, but that shouldn’t matter. I can find chrome (which I don’t use myself) in the center, but steam and nvidia are nowhere to be seen. I updated everything through dnf, rebooting several times, and other things but I can’t get them to install. I don’t suppose you could create a fresh VM and try doing this too just in case there is something I’m missing. I should also note that I am considering Fedora for my Nvidia optimus laptop and I would prefer to have everything available in the GUI even though I can use the CLI.

EDIT: Okay I’m kind of an idiot! Forgot about the reload button being under the updates tab! My bad, I think I’ll set Fedora up tonight on my laptop if I have nothing better to do. If I were to nitpick, refreshing the metadata automatically when enabling repositories would be pretty handy but whatever. Thanks a lot!

1 Like

From what I know, the nvidia bits are slightly more advanced. There isn’t one driver for all Nvidia hardware, so gnome-software detects the hardware and installs the driver for that particular hardware (there’s some magic needed for this which the RPMFusion folks take care of). So I’d at least recommend that you go through this even if you’d prefer to use Gnome-software, since it may not be straight forward.

Also, from my personal experience, the support for Optimus in the Linux Nvidia drives is not great. I could never get it to work, even with Bumblebee.

Yeh, that won’t necessarily work because updating through dnf does not update the gnome-software metadata. :frowning:

Better to quote
as bumblebee is now uneeded nowadays

Also stream remains a x86 32bit application regardless of the packaging method.
Same for many games. (aka steam runtime).
If you are using NVIDIA binary driver I recommend “against” using any flatpak over RPM packages.


Thanks @kwizart, that’s good to know.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.