Gnome Shell Extensions not working

No gnome shell extension is working, regardless of whether I installed it using dnf or the firefox extension. More precisely, as soon as I activate any extension in the firefox add-on, when refreshing, it shows up as disabled again. I’m on fedora 34, all packages are up to date.


Welcome to the community @konrad98

If you talk about firefox add on, are we talking about firefox add ons ore gnome shell add on’s?

If we talk about firefox, if you start it with the option:
--safe-mode Disables extensions and themes for this session.
can you check/confirm this?

1 Like

Hi @konrad98 , welcome to the community.

Can you please list what extensions you are using, and check if they list themselves to be compatible with Gnome 40 yet? You can do this by going to their page on

Quite a few extensions have been updated to work with the new Gnome version, but not all of them. Since most extensions are not developed by Fedora nor by Gnome the only thing to do is to wait for your extension developers to update them to support Gnome 40.

For extensions that you’ve installed using dnf, there should be bugs filed already.

A temporary workaround is to ask Gnome-shell to not check if the extension lists itself as compatible with the current version. You can do this by running the following command:

 gsettings set disable-extension-version-validation true

Please remember that this means gnome-shell will not check if the developer has marked your extension as compatible, and will try to run it. The extension may still not work, or may work partially only.

1 Like

I’m talking about the firefox add-on used to install gnome shell extensions.

Thanks for your answer! Your workaround does not work, the same thing happens. And it also happens with extensions that are compatible with gnome 40 accoridng to the gnome extensions page. The issue appears to happen with EVERY possible extension.

Can you name which is not working? I want install one and try.

1 Like

Then there’s something else happening here. I’m using a bunch of extensions here on Gnome 40 and they work just fine:

As you see, they’re both manually installed extensions (from the website) and built-in ones (system extensions installed using dnf from the repos).

Can you please tell us:

  • exactly what steps you’ve followed to install and enable extensions
  • what extensions you are trying to use

That’ll help us investigate in more detail.

How do you get this overview? I cannot see it in the gnome tweak tool. Normally, I just installed the extensions using dnf, and in addition, I tried to activate them from the firefox add-on that manages gnome shell extensions.

1 Like

The extension specific bits were split out from the tweak tool into another app:

sudo dnf install gnome-extensions-app

It’ll be listed in the Gnome overview as “Extensions”.


Thanks a lot! It seems that extensions were disabled in general, I could turn them on in this extension overview and it works as expected now.


I think if you experience a Gnome Shell crash, all extensions are automatically disabled and need to be enabled manually the next time you run Gnome Shell.


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.