"Gnome Settings" broken after update

After a resent update of Fedora 30 the update failed to complete at 98% having waited 12 hours with no change in % I restarted my laptop. To start with I thought all was Ok but later found that I couldn’t get the settings to start up from either the menu or the app. As a new user of Linux I’m not sure where to begin.

I did find this, not sure it is applicable, though will need correcting, quite how I’ll have to find out.

[*****@littlelaptop ~]$ dnf check
libssh-0.8.7-1.fc30.x86_64 is a duplicate with libssh-0.9.0-5.fc30.x86_64
libssh-0.8.7-1.fc30.x86_64 is obsoleted by libssh-config-0.9.0-5.fc30.noarch
Error: Check discovered 2 problem(s)

As I have only really used Fedora from the GUI I have spent over 2 weeks googling and not really got anywhere.

1 Like

I’m not really sure how to help you with your current problem, but I too am also swimming in the vast sea of Linux/Fedora and sometimes feel like I’m am drowning or circling around to the same place in the forest, if that makes sense.

I would however recommend setting a short-term goal of what you want to do and swimming for that shore. For me it was setting ruby/ruby on rails and that took forever. I did learn a few things, first, I’d strongly consider setting up a VM. I started using Oracles VM virtualBox, setup a Fedora 30 machine, fully updated it and then made a snapshot of it as well as a clone. So, if I do another update from here on in, and it crashes I can reset to this saved spot and start from a good base, rather than have to start all over again. (which i have done quite a few times already, including accidentally deleting my machines while trying to move them from my ssd to hdd).

Hi @evelyn—welcome to the community! Please take a minute to go through the introductory posts in the #start-here category if you’ve not had a chance to do yet.

Ah, 12 hours? That’s a lot! Something fishy there. Was this update using the Software application (assuming you are on Gnome)?

Can you make a distro sync?

dnf clean all && dnf -y distro-sync


They are not necessarily the same thing. One can have multiple versions of packages for various reasons. The root issue here is a failed upgrade, and that requires further diagnosis and changes.

May I request you to please refrain from terse solutions? I think I’ve pointed this out in another post too. Please engage with the reporter and other folks involved in the post to first figure out what the issue is before suggesting solutions. Solutions that are not fit only add to the noise and confuse people :slightly_smiling_face:

Probably the way to go, but I was hoping to get some more information from the reporter before suggesting solutions. All we know at the moment is “an upgrade seemed to fail”, but no information on when or how and what packages it may have messed up.

which quite often results in multiple versions of packages left on the system and inability to upgrade in the future because of file conflicts from different package versions. Also it can leave the dnf/rpm database in inconsistant state.

We’ve seen quite a few questions with this happening here on Ask Fedora already. In my humble opinion, the probability that the same have happened to @evelyn is quite high.

If it’s the case, then actions suggested by @vgaetera should help. I’m not sure all the commands they propose are needed and in this order (and I’m not ready to generate failed updates on my system to check), but still they should help.

I personally would probably begin with sudo dnf check all – this should help to diagnose immediate problems with dnf and packages, such as package duplicates. Also it would be useful if @evelyn posted the output of this command here for all to see and provide better informed advice.

If any duplicates are reported, then sudo dnf remove --duplicates is the way to proceed.

sudo dnf autoremove… well, i’d look at which packages it proposes to remove and see, if there’s something I think I need between them. It can potentially remove something needed – it should not when all works ok, but I’d still check.

sudo rpm --rebuilddb is a way to go if we know something wrong with rpm database… I personally wouldn’t start with it. But on the other hand maybe it wouldn’t do any harm even if the database was ok – this I simply don’t know – them we can recommend it even when we’re not sure about the database state (and failed updates can damage the rpm database, especially when computer was rebooted during the process).

dnf clean all simply deletes all the dnf caches and forces dnf to get them anew from the repository. It shouldn’t do any harm.

Regarding distro-sync – I simply don’t know if it will work (or result in transaction error as ordinary update does) in the situation with file conflicts I’ve described above, when commands provided by @vgaetera have helped people here on Ask Fedora several times.


Step 1 in my book, before anything else is done :slight_smile: :+1:

Sorry for slow reply.
1, yes was updating using the Gnome update program.
2, I have not found and other desktop program yet that shows any problems.
3, I ran as suggested by @nightromantic

sudo dnf check all
[sudo] password for *****: 
libssh-0.8.7-1.fc30.x86_64 is a duplicate with libssh-0.9.0-5.fc30.x86_64
libssh-0.8.7-1.fc30.x86_64 is obsoleted by libssh-config-0.9.0-5.fc30.noarch
Error: Check discovered 2 problem(s)

This is all the command seemed to show these being the same I found in the original post.

sudo dnf remove --duplicates

This is the output

Downloading Packages:
libssh-0.9.0-5.fc30.x86_64.rpm                  552 kB/s | 226 kB     00:00    
Total                                           107 kB/s | 226 kB     00:02     
Running transaction check
Error: transaction check vs depsolve:
libssh < 0.9.0-3 is obsoleted by (installed) libssh-config-0.9.0-5.fc30.noarch
To diagnose the problem, try running: 'rpm -Va --nofiles --nodigest'.
You probably have corrupted RPMDB, running 'rpm --rebuilddb' might fix the issue.
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.

I followed the suggested above

rpm -Va --nofiles --nodigest 

Which gave me this

Unsatisfied dependencies for libssh-0.8.7-1.fc30.x86_64:
	libssh < 0.9.0-3 is obsoleted by (installed) libssh-config-0.9.0-5.fc30.noarch
Unsatisfied dependencies for libssh-0.9.0-5.fc30.x86_64:
	libssh < 0.9.0-3 is obsoleted by (installed) libssh-config-0.9.0-5.fc30.noarch
Unsatisfied dependencies for libssh-config-0.9.0-5.fc30.noarch:
	libssh < 0.9.0-3 is obsoleted by (installed) libssh-config-0.9.0-5.fc30.noarch

I then tried

rpm --rebuilddb

this gave no output, I then re-ran the

sudo dnf remove --duplicates

which gave the same output as before

sudo dnf remove libssh-0.8.7-1.fc30.x86_64

This I have now done,
followed by

su dnf clean all && dnf -y distro-sync

which gave the output

Dependencies resolved.
Nothing to do.

This though still leaves me with no working setting app in gnome
Would this mean having to un-install gnome and re-installing
seems a bit like using a sledge hammer to crack a nut,
Also I’m not sure how I would proceed with this venture without breaking everything.

Make sure the system is up to date:

sudo dnf --refresh upgrade

Then check the output:


If there’s no output, check the log:

journalctl --follow --lines 0 & gnome-control-center
1 Like

@evelyn, I think, reinstalling gnome seems to harsh, at least at this stage.

In addition to @vgaetera suggestions (after trying them first and if they won’t give a definitive solution), you can also temporarily create a new user

sudo useradd login_for_new_user
sudo passwd login_for_new_user

In my case I was able to immediately switch to gdm (you can use either “Switch user” Gnome’s menu entry or just press [Ctrl]-[Alt]-[F1] to switch to tty1 where gdm usually lives) to see the new user there, or you may have to reboot for it to appear.

Login as new user as see if Gnome Settings opens ok for a new user.

If it does for new user but not for yours, chances are some gnome settings for your user are corrupted and force Gnome Settings to crash. In such a case deleting gnome config files and resetting setting to default can (should?) help.

If it doesn’t work for new user as well – then the problem (obviously) is system-wide and we have to look elsewhere.

To remove temporary user you can use

sudo userdel --remove login_for_new_user

–remove tells userdel to remove home catalog for user in question.


I ran these, output to 2nd was,

gnome-control-center: error while loading shared libraries: libwbclient.so.0: cannot open shared object file: No such file or directory

This seems to be part of the issue,

In addition as suggested I tried this

This showed the same issue in the new_user identity showing that it is a wider issue.

sudo dnf install libwbclient.so.0

However it’s strange.
Your system is x86_64, but the package i686-exclusive.

dnf repoquery --whatrequires libwbclient.so.0

I’m not sure if anything of those is mandatory for gnome-control-center.