Gnome-extensions-app will not launch | GSK_RENDERER=cairo

Did a update from 33 to 35 and now extensions will not launch
So did a fresh install of 35 and same result
launch form terminal and this is what I get

No provider of glGetShaderiv found.  Requires one of:
    Desktop OpenGL 2.0
    OpenGL ES 2.0
/usr/bin/gnome-extensions-app: line 2:  3260 Aborted                 (core dumped) /usr/bin/gjs /usr/share/gnome-extensions-app/org.gnome.Extensions "$@"de here

Anyone know of a fix

Gnome 40+ which came out with Fedora 34 removed the support for gnome extensions from gnome-tweaks and added the gnome-extensions-app package.

Do you have that package installed?

It also says you do not have all the proper support with opengl. I don’t know exactly which package you may need, but the command ‘dnf search opengl’ will give you lots of options to select from.

Yes gnome-extensions-app is installed that is what is not launching
Gnome-tweaks works fine
Yes I did dnf search opengl and it gave lots of options
And that is the problem I don’t know which package to install

Might be just a driver problem:

[Solved] "No provider of glGetShaderiv found" say gtk4 based apps / Applications & Desktop Environments / Arch Linux Forums

I think gnome-extensions is a flatpak app now, at least that is the only way I can get it, but the extensions are handled with the default browser now as a plugin. As in here

It certainly is not for either F34 or F35 workstation, although I cannot speak for silverblue or kinote. The following from my laptop with 35 Workstation installed.

$ sudo dnf list gnome-extensions-app
[sudo] password for jvian: 
Last metadata expiration check: 0:42:48 ago on Mon 29 Nov 2021 09:24:58 AM CST.
Installed Packages
gnome-extensions-app.x86_64                                           41~rc-1.fc35                                           @fedora

I should have mentioned that I tried the extensions flatpak also and it will not launch either
So .rpm or faltpak will not launch
I can install the extensions from the browser but the settings for the extension will not launch
I think it might be a driver problem like ilikelinux suggested, I am just not sure how to go about fixing it

Could you provide some more info about the system? @ilikelinux referenced a link that seems to suggest the issue could be i915-based; that is, if that is, indeed, your chipset, you might just be able to follow the directions here and get things rolling.

1 Like

I downloaded it as a flatpak for Silverblue/35. Works fine for me.

This is a older desktop
Dell Inspiron 530, Intel Core2 Duo E4500, Intel 82G33/G31 Express Integrated Graphics
If I am reading the graphics list correctly, this is my chipset
I also can’t find the drirc file
Am I suppose to add it to etc?
I did find a 00-mesa-defaults.conf, am I supposed to add it to that file?

It might be “safer” to just create the ~/.drirc file and put

    <device driver="i915">
        <application name="Default">
            <option name="stub_occlusion_query" value="true" />
            <option name="fragment_shader" value="true" />

In it to see what, if anything, that does.

I tried both places no change
I may try putting it in the 00-mesa-defaults.conf next

Hi, I found this on GTK Gnome issues gnome-extensions-app not working in Kali linux: “No provider of glGetShaderiv found”.

You could try the suggestion by Sebastian Keller.

… It should probably switch to the cairo backend if the hardware is too old. In the meantime you can use the GSK_RENDERER=cairo environment variable to force this.

When I check on my Fedora 35 workstation with $ dnf list installed cairo, this package already installed (maybe by default). You could try to add GSK_RENDERER=cairo on environment variable and reboot.

OK tried it 00-mesa-defaults.conf, didn’t work
So how do I enable GSK-RENDERER=cairo
Do I run it in a terminal or change it in a file or make a file?

You could add a new line on .bashrc file on your home directories (the file already exist, browse it with ls -a) with export GSK_RENDERER=cairo (beware of underscore). Then run source ~/.bashrc or log out and login again with same user.

Here are article of full explanation about how to set environment variable. It will helpful in the future.

1 Like

Thanks Syaifur Rizal that works
gnome-extensions-app works and the settings from the extensions website launch
Thanks everyone for helping

1 Like