Gnome doesn't load after update

I have just updated Fedora, but now when I boot, all I see is a black screen, the terminal cursor, and the mouse cursor.
Booting from the older kernels don’t help, and I’m lost.
Can you help me, please?

This happens after logging in, or not even the login screen appears?

not even the login screen appears.
I have also tried ctrl+alt+f2 to open terminal, but it doesn’t open.

And what about crtl+alt+f3

ctrl+alt+f3 also didn’t help

Are you able to see the boot process? (Hit ESC during boot).

Yes. Actually since the first time I have encountered this problem I sterted to see the end of the boot process, and before it didn’t show it.

Strange. Is this a laptop? Maybe function keys are reverse mapped? So you should use Ctrl+Fn+Alt+F3
Sorry if I waste your time. Maybe there is some option to add to the kernel, like nomodeset in order to start with generic video drivers, or some other option that doesn’t start the graphical interface, in order to be able to diagnose the problem from the command line, but I’m no good here.

ctrl+fn+alt+f3 works! I have a terminal.
What to do now?

1 Like

Also, using nomodeset didn’t help

Well :blush: who knows?

You could look at the logs: Viewing logs in Fedora :: Fedora Docs in order to see if there is something interesting or suggesting where the problem is.

For instance you can run this command
journalctl -e _COMM=gdm

Are you using Fedora Workstation (GNOME)?

I am using workstation.
I ran the command, and there are a lot about gdm:
“Tried to look up non-existent conversation gdm-launch-environment”
Is displayed a few times.
Also there is a red line:
“GLib: g_hash_table_foreach: assertion ‘version == hash_table->version’ failed”

Wait a minute. Those are logs from days ago.
All I see from now is:
GdmDisplay: display lasted for 1.969…
Tried to look up non-existent conversation gdm-launch-environment
Freeing conversation ‘gdm-launch-environment’ with active job

You can paste the result here, if you want.


Some other commands in order to look at something more explanatory:
systemctl status gdm.service
journalctl -e -u gdm.service
You could also look at the logs without limiting the filter to gdm:
journalctl -xe ← this is like tail -f

Which graphic card do you have?
lspci -k | grep -EA3 'VGA|3D|Display'

I have an Intel integrated HD graphics 620

Just in case your issue is a consequence of some other problem, run this command in order to get the list of (eventually) failed services:
systemctl --failed

It lists 0 loaded units

Excuse me, another question. Do you have autologin enabled?