GNOME crashes after resuming from suspend (close/open lid)

I’ve just installed Fedora Asahi Remix (39) on an M1 Air. It works really great, except for this inconvenience: if I close the lid and open it a bit later, then GNOME crashes with one or more reports. See some of the details below.

gnome-shell:

reason: gnome-shell killed by SIGSEGV
crash_function: cogl_matrix_entry_calculate_translation
package: gnome-shell-45.1-1.fc39
kernel: 6.5.11-407.asahi.fc39.aarch64+16k
os_release: Fedora Asahi Remix release 39 (Thirty Nine)

gnome-tweaks:

reason: python3.12 killed by SIGSEGV
crash_function: gdk_wayland_device_update_window_cursor.lto_priv.0
cmdline: /usr/bin/python3 /usr/bin/gnome-tweaks
package: gnome-tweaks-45.0-1.fc39

I’ve tried to send in the crash report, but pressing Report results in another error:

Element 'os' is invalid: Element 'name' is invalid: Only the following values are allowed: centos, fedora

For some reason, running systemctl suspend and waking up using the power button works fine, just not closing/opening the lid.

Edit: I see now that the first bug has already been reported. Not sure how to report the issue with the Report feature itself, however.

1 Like

I am seeing the same problem after upgrading to Fedora 39.

The link you have posted on RH bugzilla does not appear to be the same issue, though.

1 Like

Interesting to hear that the problem wasn’t present in Fedora 38. So what is the right place to report these two bugs (1: GNOME crashing; 2 the broken crash report feature)?

1 Like

Found these two things

gnome-shell process gets killed after locking screen when using RT KMS thread (#3037) · Issues · GNOME / mutter · GitLab and Crash after waking up from automatic suspend (#7102) · Issues · GNOME / gnome-shell · GitLab

Maybe @marcan or @jannau could help look over these or maybe ELI5 it for us :smiley:

I am experiencing a very similar issue that materialized after I upgraded Mesa. I reported it to upstream here: gnome-shell crash on lock screen (#7199) · Issues · GNOME / gnome-shell · GitLab

Thanks Yussef! Yes, I tried downgrading MESA twice, as you described and it made the issue disappear. It also made the GNOME x11 crashes disappear.

Excellent news! So is this a bug in apple_dri? Some display driver portion for Apple GPU?

apple_dri is just “all of mesa”. The libraries are hardlinked, the filename is just an artifact of how the drivers are loaded. You need to look at the stack trace to figure out if this has anything to do with our actual driver or not.

Thanks @marcan. I didn’t realise that’s how it worked :smiley: I think that report on the gnome tracker has a stack trace, I’ll double check

@albsod Moving back from the other thread, I just pushed a Mesa update with some misc fixes. Can you confirm whether the suspend/resume issue is still there?

You probably still want to remove /usr/lib64/dri/zink_dri.so after the update until the glibc issue is solved and the updates for that are available (even on Wayland, just in case the underlying issue is still there somehow and causing other trouble).

@marcan After applying your latest updates I’ve closed and opened the lid a dozen times and not experienced any crashes so it looks promising! For reference, I left /usr/lib64/dri/zink_dri.so in place.

@ydalton and @scidoner, could you try this as well?

I installed the latest Mesa a few hours ago, and I have not experienced any crashes (yet), although I think it is too early to tell. I will let you know if something comes up.

I had this same issue happen to me, but while I was in the middle of working on something. I can’t recall if I had just unlocked the computer, but I don’t think I had opened the lid recently.

https://retrace.fedoraproject.org/faf/reports/928840/