Gnome 42: I'm .. freaking out about color scheme consistency, I just want this to work


So I’ve gone from F35 to F36 because I couldn’t get my colorscheme to be consistent across applications. flatpaks, snaps presenting additional challenges, with which I have had … mixed results

But even just in gnome, some use GTK2,3 or 4 and even the gnome apps aren’t following the same colorscheme. It’s beyond frustrating.

I was hoping moving to F36 with Gnome 42 would make things “easier” but it seems to throw yet another variable into the mix, and has made consistent “theming” (or is it color scheme?) more frustrating

I LITERALLY just uninstalled all the desktop apps, or so I thought - I did a "dnf group remove “Fedora Workstation”, and any additional theme files or flatpaks I had, thinking maybe I could reboot to a terminal and group install Pantheon Desktop in case that would be easier

Now I am back in Gnome because apparently that was protected and I couldn’t uninstall it, I probably had to switch systemctl defalt target first (I did all these uninstallations at console outside of a DE)

I am TIRED of trying to troubleshoot things, it’s taking way too much of my time and I just want it to work. I JUST DON’T CARE about anything mildly significant anymore.

I don’t care about theme (shape, padding, layout), I only want everything to be in dark mode (I recently learned “theme” and “colorscheme” are different, so please forgive me if I use them interchangeably)

My situation:

Gnome 42, jumped on F36 early, happy with everything but colorscheme
I am using flatpaks, snaps and appimages
I am happy to use libadwaita or yaru or whatever if that’s the only theme that has all the functionality necessary
I just want all the apps to be dark

Can somebody help me? for the love of god, please …

Edit: I forgot gsettings and xdg-desktop-portal as being additional variables rife with pitfalls, I will forego QT applications for right now … christ what a cluster

Here is a blog post with an explanation of what is going on. I hope it will help you fix your problems, but I doubt it. In short, GNOME now relies exclusively on libadwaita. Older GTK applications have to be re-coded to conform. Some applications have been, but most haven’t.

1 Like

Another factor is that the DE cannot force an app to use the system (DE) color scheme. Those that have their own scheme will happily use it in spite of what the DE uses. This is one of the factors involved in having FOSS since it allows the app developer their own choice of how their app appears to the user.

In fact, the variety of DEs available to a user makes it almost imperative that the developer choose how his app appears so it is portable and just-works in all the different DEs.

Thanks to everyone who wrote to help. Sorry, it’s probably obvious I was very frustrated when I wrote that. I was trying to clean it up, but then got tagged for spam and the post got hidden before I could explain I figured out what appears to be the main issue I was having

I think most of my GTK3 issues have been solved by setting:

dconf write /org/gnome/desktop/interface/gtk-theme Adwaita-dark

(note, I performed this with dconf-editor gui application so I am not positive this is the correct syntax)

if I am correct in thinking there are essentially 2 themes that are acceptable by GTK4 standards: Yaru and Adwaita. AFAIK Adwaita is the default so I stuck with that. Just setting this dconf setting basically cleared up most the problems I was having - simultaneously having both dark and light mode applications was the most annoying issue.

Now, I could have stopped there, but there is an Adwaita GTK3 theme re-written to look like the GTK4 version here, since the GTK3 and GTK4 versions are apparently a bit different: GitHub - lassekongo83/adw-gtk3: The theme from libadwaita ported to GTK-3

And a flatpak on flathub named org.gtk.Gtk3theme.adw-gtk3-dark - source: GitHub - flathub/org.gtk.Gtk3theme.adw-gtk3-dark

I actually downloaded the .tar.gz from releases and decompressed it in ~/.local/share/themes, but I think I could have created a symlink to the flatpak, e.g.

mkdir -p ~/.local/share/themes/adw-gtk3-dark
ln -s /var/lib/flatpak/runtime/org.gtk.Gtk3theme.adw-gtk3-dark/x86_64/3.22/active/files  ~/.local/share/themes/adw-gtk3-dark/gtk-3.0

as I have diff-ed these files (flatpak vs GH release) and they appear to be equivalent. I also stuck another symlink from ~/.local/share/themes/adw-gtk3-dark to /usr/share/themes/adw-gtk3-dark as well, just for good measure

Then obviously I had to set the dconf setting to reflect the different name:

dconf write /org/gnome/desktop/interface/gtk-theme adw-gtk3-dark

The last thing I have to figure out is whether I need QPA_PLATFORM_THEME or QT_THEME_OVERRIDE set for Dolphin not to have a light-colored theme for its icons. :confused: So this kinda sucks. But the main issues I was having appear to be mostly cleared up.