Getting the default alert sound back?

The default alert sound of Fedora is some kind of dripping sound, but it’s not one of the option in GNOME Settings → Sound → Alert Sound menu and is shown as “unknown”. Thus once I opened the menu, the setting automatically changed to the “Click”.
How do I get the default sound back?

The same thing happened to me. This is how I got the default alert sound back in Fedora 39:

  1. Install GNOME Tweaks
    Search for Tweaks in the Software app or install it by entering this command in the terminal: sudo dnf install gnome-tweaks -y
  2. Open Tweaks.
    You can find it in the Utilities folder of the Apps menu or enter gnome-tweaks in the terminal.
  3. Go to the Sound sub-menu.
  4. Change System Sound Theme to Default.

You will now have the dripping alert sound, despite the Settings app still showing “Click” (or whatever else you selected) as the alert sound.

I hope this helps!

I dug a bit deeper on this. panels/sound/cc-alert-chooser-window.c · main · GNOME / Settings · GitLab
It seems that GNOME Settings creates a __custom sound theme that inherits from freedesktop once you touch the alert sound setting. And set org.gnome.desktop.sound theme-name to it. The theme is in ~/.local/share/sounds/__custom and setting the alert sound is creating the 2 symlink inside.

$ gsettings get org.gnome.desktop.sound theme-name

On a fresh install the theme-name is freedesktop, and the custom theme folder doesn’t exist.

$ gsettings get org.gnome.desktop.sound theme-name

Getting the alert sound fails (“unknown”) probably because freedesktop theme doesn’t have a file called bell-terminal.ogg, just bell.oga. Though strangely, in Ubuntu, there is an extra option called “Default” in alert sound.
Edit: “Default” in Ubuntu sets the theme-name back to “Yaru”.