Getting Canon Lide 400 to work on Fedora 31


I am trying to get Canon Lide 400 scanner to work with Fedora 31. I have xsane installed, xsane recognizes the device when started. See the attached screenshot.
But when I try to get a preview or a scan, xsane hangs or throws an error I/O error communicating with the scanner.

I also tried to get the drivers from the Canon site

But they have only .deb files. An attempt to convert these .deb files to .rpm using alien package results in errors

$ alien --scripts -rk scangearmp2_3.70-1_amd64.deb

Package build failed. Here’s the log of the command (cd scangearmp2-3.70; rpmbuild --buildroot=‘/home/damitr/Downloads/scangearmp2-3 (1).70-1-deb/packages/scangearmp2-3.70’ -bb --target x86_64 ‘scangearmp2-3.70-1.spec’):
Building target platforms: x86_64
Building for target x86_64
Processing files: scangearmp2-3.70-1.x86_64
error: File must begin with “/”: (1).70-1-deb/packages/scangearmp2-3.70/usr/lib/.build-id
error: File must begin with “/”: (1).70-1-deb/packages/scangearmp2-3.70/usr/lib/.build-id/02
error: File must begin with “/”: (1).70-1-deb/packages/scangearmp2-3.70/usr/lib/.build-id/02/8fbac2701f687da994b21fb506a92aedb587c3

RPM build errors:
File must begin with “/”: (1).70-1-deb/packages/scangearmp2-3.70/usr/lib/.build-id
File must begin with “/”: (1).70-1-deb/packages/scangearmp2-3.70/usr/lib/.build-id/02
File must begin with “/”: (1).70-1-deb/packages/scangearmp2-3.70/usr/lib/.build-id/02/8fbac2701f687da994b21fb506a92aedb587c3

Any ideas on how to resolve these errors or any other method to get the scanner working?

1 Like

Hello … @damitr ! Welcome to the community! Please do take a few minutes to go over the introductory posts in #start-here when you have the time. They contain lots of useful information.

You donwload the DEBIAN package, that is for DEBIAN and derivates, Download the RPM package is for REDHAT, FEDORA and CENTOS:

ScanGear MP Ver. 3.70 for Linux (rpm Packagearchive)

System Requirements Fedora 28(32bit/64bit) and later

and install it as usual, via:

sudo dnf install *.rpm 



Thanks for the link. I have got the scanner to work with scanimage on the terminal

scanimage -d pixma:04A91912_421C5A --resolution 600 --mode Color --format jpeg >scan2.jpeg

It is also working with other gui based programmes like Document Scanner and gscan2pdf, but the problem with xsane still persists.

Xsane recognizes the scanner, but hangs as I click on preview or scan buttons. Any ideas on what might be the problem?

Edit: Issue is solved, by default the ‘button controlled scanning’ in xsane was enabled.
Standard Options > Button Controlled Scan. With this option disabled xsane is working fine.

Got a hint from this post


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.