GDM is not giving me any display even though is running


After upgrading from Fedora 35 to Fedora 36, i realized that NVIDIA driver was not working so i decided to reinstall the driver, after that, i faced a new issue which is that now the GDM is not working when im using X11, it worked perfectly the first 2 restarts, but after that i started to face new problems, those problems were specifically that the screen was showing me the image correctly for a few seconds but after that the display was under something like a filter which describes the picture im posting down below.

I already tried to modify the gdm’s configuration file “/etc/gdm/custom.conf” to force the execution of Xorg (it helped me to at least show the screen for a few seconds, but after that the screen is dead). Note that i can still login with my password even though i can’t see anything.

I also tried to switch between different display managers but none of them worked correctly but XDM, the problem with XDM is that it makes my GNOME work slowly (i don’t know why, but it is happening), but i would like to make my GDM work again. Right now i have to options to login to my system, which are login without seeing anything displayed on my screen or login from TTY and then type startx.

Finally i would like to add that i already done this:

  • Reinstall NVIDIA Drivers manually 3 times
  • Uninstall NVIDIA Drivers installed manually and then install them from RPM Fusion.

Right now I have the NVIDIA Drivers installed manually.