GDM fails for xorg sessions. VM. Fresh Install

Apologies but I’m not the most linux savvy but I’ll try to include what I know. I’ve got a fresh install of Fedora 39 on a VM hosted in hyper-v. I have done nothing with the VM except the initial setup prompts where I chose to enable the 3rd party repos. From the login manager none of the xorg options for gnome work. Logging in after selecting an xorg option just returns me to the username/password field. In a previous install/vm I had installed plasma + SDDM and ran into the exact same issue with xorg sessions. To be clear, there is no issue with the default Wayland option, only an issue if an xorg option is selected.
I’ve included the tail end of xorg.0.log with the error messages. If there’s anything else that’s need I can provide. I know wayland’s thing is that it doesn’t run as root and there are several permission denied messages in that log, is there something else I have to do to let xorg run as root? Are there some specific drivers I need when working with X instead of wayland? Any next steps of suggestions would be appreciated.

[  3328.336] (II) FBDEV: driver for framebuffer: fbdev
[  3328.337] (II) VESA: driver for VESA chipsets: vesa
[  3328.337] xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
[  3328.337] (WW) Falling back to old probe method for modesetting
[  3328.337] (II) modeset(1): using default device
[  3328.337] (II) Loading sub module "fbdevhw"
[  3328.337] (II) LoadModule: "fbdevhw"
[  3328.337] (II) Loading /usr/lib64/xorg/modules/libfbdevhw.so
[  3328.337] (II) Module fbdevhw: vendor="X.Org Foundation"
[  3328.337]    compiled for 1.20.14, module version = 0.0.2
[  3328.337]    ABI class: X.Org Video Driver, version 24.1
[  3328.337] (EE) Unable to find a valid framebuffer device
[  3328.337] (WW) Falling back to old probe method for fbdev
[  3328.337] (II) Loading sub module "fbdevhw"
[  3328.337] (II) LoadModule: "fbdevhw"
[  3328.337] (II) Loading /usr/lib64/xorg/modules/libfbdevhw.so
[  3328.337] (II) Module fbdevhw: vendor="X.Org Foundation"
[  3328.337]    compiled for 1.20.14, module version = 0.0.2
[  3328.337]    ABI class: X.Org Video Driver, version 24.1
[  3328.337] (EE) open /dev/fb0: Permission denied
[  3328.338] vesa: Refusing to run, Framebuffer or dri device present
[  3328.338] (II) modeset(G0): using drv /dev/dri/card0
[  3328.338] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[  3328.338] (EE) Screen 0 deleted because of no matching config section.
[  3328.338] (II) UnloadModule: "modesetting"
[  3328.338] (EE) Screen 1 deleted because of no matching config section.
[  3328.338] (II) UnloadModule: "fbdev"
[  3328.338] (II) UnloadSubModule: "fbdevhw"
[  3328.338] (EE)
Fatal server error:
[  3328.338] (EE) Cannot run in framebuffer mode. Please specify busIDs        for all framebuffer devices
[  3328.338] (EE)
[  3328.338] (EE)
Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
[  3328.338] (EE) Please also check the log file at "/home/glethro/.local/share/xorg/Xorg.0.log" for additional information.
[  3328.338] (EE)
[  3328.340] (EE) Server terminated with error (1). Closing log file.

Issue is probably pretty clear to the Fedora guys but for anyone else running Hyper-V the problem is related to selecting Gen1 vm instead of Gen 2. Switch to gen 2 and disable Secure Boot and problem is solved.