GDM does not list my user anymore / gnome initial setup runs instead

After upgrading to Fedora 30 today and also running sudo rpmconf -a (not sure if related) GDM fails to see my user: instead of providing me the login screen to input my password I get logged in automatically as the gnome initial user and need to run the setup tool. At the end of the setup tool I cannot pick my default user as username, it identifies that this is not possible.

As a workaround I forced gdm to not do auto login: I added AutomaticLoginEnable=false to /etc/gdm/custom.conf.

However, even in that case my user is not shown in GDM login screen, but I have to enter the name manually.

And idea how to teach GDM properly where to find my user?

1 Like

Since you can edit config files I assume you can get access to the system in some way – are you doing that with a root account? Do you know if /etc/passwd is one of the files changed by rpmconf -a? (It shouldn’t have been, but… maybe?) What does that file look like? Is your account in there?

1 Like

I can login with the user in ttys - or even on GDM if I disable autologin. So /etc/passwd is fine, my account is listed there. From the usual system perspective the user is working.

It is just that for some reason GDM, on its own, does not recognize that there is a user on the system. Autologin brings me straight to gnome initial setup user. If I deactivate auto login, my user is still not listed in the gdm login screen. But I can provide my user name and password there, and can normally login to a gnome session.

Hmmm. What’s your numeric user ID?

1 Like

The numeric id is fine as well:

$ id
uid=1000 ...

Some more news here: checking the gdm service I found the following error:

Mai 01 00:29:40 schwarzschild systemd[1]: Started GNOME Display Manager.
Mai 01 00:29:43 schwarzschild gdm-launch-environment][1660]: accountsservice: Could not get current seat: No data available
Mai 01 00:29:48 schwarzschild gdm-password][2030]: accountsservice: Could not get current seat: No data available
Mai 01 00:29:50 schwarzschild gdm-password][2030]: gkr-pam: unable to locate daemon control file

I’ll dig deeper into this and keep this thread posted.

But thanks for the help so far!

1 Like

Maybe a problem with: accounts service → D-Bus interfaces for querying and manipulating user account information…

Could you please share with us this information:

tree /var/lib/(A|a)ccounts(s|S)ervice

and cat of this files inside ***users *** directory

You should have three file inside it:

gdm, gnome-initial-setup, and another file indicating your user file , example my is hhlp

also check permission in this directory, owner by root, here is mine

ls -l /var/lib/[A-a]ccounts[S-s]ervice

drwxr-xr-x. 2 root root system_u:object_r:accountsd_var_lib_t:s0 4096 abr  5 11:32 icons
drwxr-xr-x. 2 root root system_u:object_r:accountsd_var_lib_t:s0 4096 may  2 09:29 users

ls -l /var/lib/[A-a]ccounts[S-s]ervice/users

-rw-r--r--. 1 root root system_u:object_r:accountsd_var_lib_t:s0  70 may  2 09:29 gdm
-rw-r--r--. 1 root root system_u:object_r:accountsd_var_lib_t:s0  82 abr  4 20:19 gnome-initial-setup
-rw-r--r--. 1 root root system_u:object_r:accountsd_var_lib_t:s0 122 abr  5 11:32 hhlp


you can also add the -Z to Display SELinux context of this directory/files

NOTE: I also have that messages in my log and I don’t have problem

What did you do?

Rpmconf search for config file (or all installed packages) and check:

  • .rpmsave , is a copy of your original configuration file, which has been replaced by the new default file.
  • .rpmnew , file contains the new default configuration file and leaves your original configuration file untouched.
  • .rpmorig , (the original configuration file , one not owned by a package)

all that files are generating in update process, In such case, if you want to keep current version, put back old version or see diff of those two files.

to find out :

find / -print | egrep "rpmnew$|rpmsave$"

You’ll never do that in and release upgrade, generally new release came with new changes in config files … If Is this what you want? you should compare this files one by one make a backup and change the new…


Hi @hhlp, thanks for the pointer to accountsservice - I found reports about that acting up as well and “fixed” it:

  • I fore-removed the /var/lib/AccountsService
  • I reinstalled the package accountsservice

That did the trick for me - but was understandably something you should not do if you need to be careful with your system. If the problem comes up with one of my other systems I will try to analyze it more carefully, just as you suggested, @hhlp!

Thanks again,


I was on the exact situation as @liquidat
after unistalling zsh using: dnf remove zsh
and forgeting to restoring shell to bin/bash to my user.
When i restore the default shell i can’t see my user on GDM
but /etc/passwd , /etc/group and my personal folder was ok.

Heres the output for the commands suggested by @hhlp
before any modification

$ tree /var/lib/[A-a]ccounts[S-s]ervice

├── icons
└── users [error opening dir]

$ sudo tree /var/lib/[A-a]ccounts[S-s]ervice

├── icons
└── users
├── gdm
├── gnome-initial-setup
└── technotrancer

$ ls -l /var/lib/[A-a]ccounts[S-s]ervice
drwxrwxr-x. 1 root root 0 Nov 26 22:08 icons
drwx------. 1 root root 70 Nov 26 22:09 users

$ sudo ls -l /var/lib/[A-a]ccounts[S-s]ervice/users
-rw-r–r–. 1 root root 70 Nov 26 22:09 gdm
-rw-------. 1 root root 82 Nov 26 21:53 gnome-initial-setup
-rw-------. 1 root root 77 Nov 26 22:01 technotrancer

So, based on the permissions in the output of @hhlp then i run

sudo chmod go=rx /var/lib/AccountsService/users/
sudo chmod go=r /var/lib/AccountsService/users/technotrancer
sudo chmod go=r /var/lib/AccountsService/users/gnome-initial-setup

And finally (this last will logout you)
systemctl restart gdm.service

and that fixed my GDM issue.


1 Like

After I upgrade Fedora 35 to Fedora 36, I also get the same status - GDM can not show my user list. My user’s default is ZSH during upgrading to Fedora 36. So I finally fix this issue:

  1. change back to BASH
$ sudo chsh -s /usr/bin/bash <username>
  1. Logout and check if GDM shows my user list. It will work!
  2. Login and change to ZSH
$ sudo chsh -s /usr/bin/zsh <username>
  1. Logout and check it out again. It works now!

But in Step 3, I get the message: “/usr/bin/zsh is not existed in /etc/shells”. Please add it to /etc/shells manually.