FYI: Printing from Fedora Silverblue 39 to an Epson Workforce 435

I’ve just spend the past few days getting my Epson Workforce 435 working under Fedora SIlverblue 39.

When I added the printer under Settings → Printers → Unlock, it assigned the driver for the “Epson Workforce 315”. Unfortunately, this driver did not work: the printer just formfeeded its way through all of the paper.

I downloaded the drivers for the Workforce 435 from Epson:

Enter product name: workforce 435
Operation system: Linux

Epson Inkjet Printer Driver (ESC/P-R) for Linux for RPM
Version: 1.8.5
Release Date: 03-15-2024

I tried installing the driver in a Toolbox container.

$ sudo dnf install ./epson-inkjet-printer-escpr-1.8.5-1.x86_64.rpm

This did not work: same result with paper formfeeding (I uninstalled the driver).

It wasn’t until I installed the driver as a local layered package that I have been able to print.

$ sudo rpm-ostree install ./epson-inkjet-printer-escpr-1.8.5-1.x86_64.rpm

I then selected the driver from Settings → Printers → Unlock → [Workforce 435] printer entry-> [Triple Vertical Dot] pulldown menu → Printer Details → Select from Database → Manufacturer: Epson → Driver: Epson Workforce 435 → Select

(Previously, the drivers only went up to “Epson Workforce 315”, then skipped to “Epson Workforce 500”, iirc.)

Hopefully this helps someone from the future (most probably me in 18 months or so :smiley:)

~N

2 Likes