Fresh install of F37 KDE - Setup screen has no content

I have just installed F37 KDE. When I log in it tries to do the initial setup, but there is no content in the menu. There are still a few things present, like the Fedora logo and a few buttons that aren’t part of the setup (e.g. help, quit), but pressing them does nothing. After around a minute the mouse cursor disappears. Not sure if this is relevant, but it is an encrypted install.

Welcome to Ask Fedora! Instead of logging-in press Ctrl+Alt+F3, log in there and try to update the system:

sudo dnf dsync --refresh

You’ll need an internet access for that to complete (preferably wired, because for Wi-Fi you’ll have to connect with nmcli).
If that doesn’t help, post here output of sudo inxi -SMGDaz

Sorry for the late response. I have learned something new while fiddling around: this is at least partially tied to my use of encryption. When I tried installing without the encryption, it opened the same empty initial setup screen, but after about 5-10 seconds the screen closed itself and the OS worked normally. Reinstalling with encryption, however, this does still occur. I would unfortunately like to use encryption, so that won’t help me.

I’m not really sure why past me said that I had to “log in” to start the initial setup, as it triggers immediately upon decryption without a login screen. Because of this, the provided keybind doesn’t work, so I can’t try either of the suggested steps. In case it is useful, here is the result of sudo inxi -SMGDaz run on the live USB that I used for installation:

  Kernel: 6.0.7-301.fc37.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.38-24.fc37 parameters: BOOT_IMAGE=/images/pxeboot/vmlinuz
    root=live:CDLABEL=Fedora-KDE-Live-37-1-7 quiet rhgb
  Console: pty pts/1 wm: kwin_wayland DM: SDDM Distro: Fedora release 37
    (Thirty Seven)
  Type: Laptop System: Dell product: XPS 15 9520 v: N/A serial: <filter>
    Chassis: type: 10 serial: <filter>
  Mobo: Dell model: 0MWGD4 v: A00 serial: <filter> UEFI: Dell v: 1.8.1
    date: 10/13/2022
  Device-1: Intel Alder Lake-P Integrated Graphics vendor: Dell driver: i915
    v: kernel arch: Gen-12.2 process: Intel 10nm built: 2021-22+ ports:
    active: eDP-1 empty: DP-1, DP-2, DP-3, DP-4, HDMI-A-1 bus-ID: 0000:00:02.0
    chip-ID: 8086:46a6 class-ID: 0300
  Device-2: NVIDIA GA107M [GeForce RTX 3050 Mobile] vendor: Dell
    driver: nouveau v: kernel non-free: 520.xx+ status: current (as of 2022-10)
    arch: Ampere code: GAxxx process: TSMC n7 (7nm) built: 2020-22
    bus-ID: 0000:01:00.0 chip-ID: 10de:25a2 class-ID: 0302
  Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 3-6:2 chip-ID: 0c45:6a15 class-ID: 0e02
  Display: server: X.Org v: 22.1.3 with: Xwayland v: 22.1.3
    compositor: kwin_wayland driver: X: loaded: modesetting unloaded: fbdev,vesa
    dri: iris gpu: i915 display-ID: :1 screens: 1
  Screen-1: 0 s-res: 1920x1200 s-dpi: 96 s-size: 508x318mm (20.00x12.52")
    s-diag: 599mm (23.6")
  Monitor-1: eDP-1 mapped: XWAYLAND0 model: Sharp 0x1515 built: 2021
    res: 1920x1200 hz: 60 dpi: 143 gamma: 1.2 size: 340x210mm (13.39x8.27")
    diag: 396mm (15.6") ratio: 16:10 modes: 1920x1200
  API: OpenGL v: 4.6 Mesa 22.2.2 renderer: Mesa Intel Graphics (ADL GT2)
    direct render: Yes
  Local Storage: total: 536.69 GiB used: 6.55 GiB (1.2%)
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
    model: PC SN810 NVMe WDC 512GB size: 476.94 GiB block-size: physical: 512 B
    logical: 512 B speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 61520012 temp: 43.9 C scheme: GPT
  SMART: yes health: PASSED on: 13d 6h cycles: 225
    read-units: 20,994,216 [10.7 TB] written-units: 20,491,574 [10.4 TB]
  ID-2: /dev/sda maj-min: 8:0 type: USB vendor: Samsung model: Type-C
    size: 59.75 GiB block-size: physical: 512 B logical: 512 B type: N/A
    serial: <filter> rev: 1100 scheme: GPT
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?

Edit: As ozeszty mentioned below, if you are experiencing this issue you should first attempt to boot with the nomodeset kernel argument. If the boot works, then the issue is with your graphics drivers rather than the setup screen.

Well I have done something potentially stupid, so please tell me if it was a mistake lol. I tracked down that the initial setup screen is run through Systemd, so I disabled the link between Systemd and the initial setup. The way I did this was by loading my Fedora file system on another OS on my computer, and deleting the following files:


After that, I was able to start up and everything worked. The only issues I have had so far are NVIDIA drivers :frowning: which based on the error log may have been the cause of the issues with the initial setup. However, now that I have fixed my drivers I don’t really care enough to figure out how to re-enable it so I can find out.

1 Like

In that case it’s better to boot with nomodeset kernel argument, install nvidia driver and then start-up normally.

1 Like

In hindsight that would have been better, but I was not aware that graphics drivers were the issue until after I had disabled the initial setup.

Good idea with editing the solution.
If your system haven’t went through the initial setup, you might be missing something. I haven’t checked what it does exactly, it finishes in the blink of an eye on AMD and Intel GPUs.

I figured it was just more settings which, being the settings freak that I (and most Linux users) am, would get around to fixing myself anyway. I haven’t had time to do anything yet so I guess I’ll just reinstall and try nomodeset. Will update with results.

In this case, the issue was that I didn’t have the proper NVIDIA drivers and it caused the setup screen to crash. Booting with the nomodeset kernel argument allowed me to complete the setup screen and then install new drivers.

If this step doesn’t work for you, I discovered that you can disable the setup screen entirely by loading your Fedora filesystem in another OS and deleting the following files:


However, this may have unintended consequences as I don’t really know what the setup screen is doing in the background.