Flutter development on Silverblue EGL error

I’m considering moving to Fedora Silverblue and have been doing some tests in a VM before I make the jump to install it on hardware. One thing I tried was running flutter for desktop development in a Toolbox, and basically it doesn’t work. I can provide full reproduction steps if necessary, but basically I’m using latest stable release of flutter and trying to run the default demo application with device “Linux (desktop)”. It start the application and I even get a window, but the window is blank and I get this error message:

libEGL warning: DRI2: failed to authenticate
libEGL warning: MESA-LOADER: failed to open swrast: /usr/lib64/dri/swrast_dri.so: cannot open shared object file: No such file or directory (search paths /usr/lib64/dri)

** (linux_app:9878): WARNING **: 01:11:30.417: Failed to start Flutter renderer: Failed to initialze EGL

The error references usr/lib64/dri, which i think is related to graphics drivers? It exists on the system but not inside the container.

How can I get graphics drivers to work inside of a container? Is it a package I should install or something about how the container is configured?

1 Like

I solved the issue. In short, I needed to install mesa dri drivers and then openGL worked like expected.

# dnf install mesa-dri-drivers

1 Like