Flatpak icon are not showing up in menu

Problem not solved

You have to then log out and back in for it to take effect. The usermod command only changes the configured shell, not the one currently in use.

Now the terminal is not opening even after restarting

Try logging into a TTY as root.

Also, I don’t recommend changing the shell for the root user. If you break that user too, you will have no way to login at all and the fix gets much more complicated.

I am using gnome.

One thing I have found with certain flatpaks installed in user mode is that the .desktop file is installed under the ~/.local/share/flatpak with the rest of the pak, but is not copied to ~/Desktop.
When I placed a copy of that file into my users ~/Desktop directory then the icon appeared in the activities menu for my user.

The original issue was because they were using fish as the default shell.

However, subsequent removal of fish without changing the shell and then trying to fix the issue has created the current situation.

1 Like

What should I do now?
I have no access to use the terminal, my X11session is not working, my dnfdragora is also not working since it’s installed making me not install any package. Timeshift is not opening since moved from copr package to default fedora repo package which is not working since the inception of fedora 35.
Anything I can do apart from a fresh install?

Somehow solved the issue.
Installed Terminator from Plasma Discover
Installed Timeshift from Terminator
Restored the 21st November snapshot
Boom! back to normal – Grateful to BTRFS Snapshots

1 Like

Now anyone help me to unistall fish and safely change to the default shell
Or if there are no serious problems with fish then suggest me a way to manually write flatpak apps to the menu directory

Followed these instructions and successfully came out of fish.

Uninstalling fish

Should you wish to uninstall fish, first ensure fish is not set as your shell. Run chsh -s /bin/bash if you are not sure.

Next, do the following (assuming fish was installed to /usr/local):

rm -Rf /usr/local/etc/fish /usr/local/share/fish ~/.config/fish rm /usr/local/share/man/man1/fish*.1 cd /usr/local/bin rm -f fish mimedb fish_pager fishd fish_indent

Run this as normal user and above mentioned as super user(root)

chsh -s /usr/bin/bash
1 Like

Finally Flatpak apps are in the Menu.

Anyone suggest me shells like fish which don’t interfere with any other operations

Can I use this instead of fish? (I want to use along with Alias feature)

Synth Shell

Personally I use zsh, mostly because of how well the autocomplete function works.

Alias is also available in bash and zsh.

Have a look at, Tuning your bash or zsh shell on Fedora Workstation and Silverblue - Fedora Magazine

You may want to start a new thread with the shell questions since the flatpak issue has been resolved.


1 Like

But what’s the problem with non-POSIX that happened to cause this issue?
And how to determine if a script or shell is non-POSIX or not?


a non-POSIX or not?

Fish flatpak issue

I started a new thread for this!


1 Like