Flathub Flatpak Repository Inaccurately Named By Default

Heyo!

I don’t know where to put this, but I wanted to bring it to the attention of folks that the filtered Flathub repository is named flathub by default, which conflicts with the actual repository from Flathub, which results in oddities when trying to add it, as the repo “already exists”.

The default, filtered repository should have a name like “flathub-filtered”, so as not to conflict with the official Flathub repository and its installation instructions.

2 Likes

Because of this issue, I couldn’t add the flathub repo on Silverblue 37 by the use of terminal and the official instructions from flatpak.org. I finally set up the flathub repo by downloading the repository file.

2 Likes

Same here +1

Hello @schykle and @piotr ,
You could of course use flatpak remote-modify --title=flathub-filtered flathub to rename the fedora filtered list version instead. The install of the official flathub remote would proceed as expected then since it didn’t exist anymore.
I find some of flatpaks administration tools get overlooked. I think its a lack of user faced documentation for the project (flatpak in this case).

4 Likes

TL;DR I think this issue has been resolved, likely upstream in the fedora-third-party package.

Ran into this issue on a Fedora system I set up about a year ago. Was wondering if it’s still an issue so I grabbed a fresh Fedora 38-1.6 ISO (latest) and fired up Boxes. After booting I opened /var/lib/flatpak/repo/config and confirmed there’s no Flathub/Flatpak configuration by default, as expected. Then I opened up GNOME Software and clicked Enable for third party software repositories and went back and checked the /var/lib/flatpak/repo/config again. Everything appears to be named properly now i.e. no more “Fedora Flathub Selection” for the non-Fedora specific, standard flathub repository entry.