Flameshot requires a version of Qt5 different from the available and installed

I used to use flameshot v. 0.5.1 to take screen prints, and it worked fine for quite some time.
Now I am trying to run it, but it throws the following error:

flameshot: /lib64/libQt5Core.so.5: version `Qt_5.12’ not found (required by flameshot)

And indeed, the version of Qt5 that is available in the repository and installed is Qt5 5.9.4

When I check the “requires” for flameshot version 0.5.1 in dnf, this is what I see:

 --> qt5-qtbase-5.9.4-4.fc26.x86_64
 --> qt5-qtbase-5.9.4-4.fc26.x86_64
 --> qt5-qtbase-5.9.4-4.fc26.x86_64

At this point I am confused why flameshot complains that a version of Qt5 different from that which it requires is missing. I do have Qt5 5.12 installed via its online tool into ~/home/Qt. How could I point flameshot at this installation instead of the one under /lib64?

Hiyya all! By the time the post got approved, I found a solution to it.
It looks like flameshot had been installed when Qt 5.12 was available on the system somehow (not sure how, but anyway). Then it got removed and reinstalled, and flameshot lost it somehow.
I ran sudo dnf reinstall flameshot and it is working again.


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.