Flameshot does not work at Fedora Workstation 39

Hello friends

For Fedora Workstation 39, installed through VirtualBox, was installed Flameshot with the sudo dnf install flameshot command. Even when the OS was re-started, when through Show Apps for the Flameshot icon:

  1. is accomplished double left click nothing happens
  2. With right click appears the contextual menu and doing click at the Open launcher item, after of some seconds, appears at the top of the screen, just below of the clock, a small Window with the Flameshot Error - Unable to capture screen message and below other Window with some settings and including the Take new screenshot button. If the mentioned button is clicked this (2) case happens again.

If with the Right Click for the mentioned contextual menu:

  • is selected the Configure item then is opened the expected window
  • Is selected the Take screenshot item happens the point 2 but without the second window

What is missing? Some extra configuration? Some extra package to install? or is it a bug?

Flameshot has no Wayland support afaik.

I recommend these instead:

  • GNOME, KDE: preinstalled screenshot tools
  • windowmanagers: grim

LXQt’s tool probably works

Greenshot can use grim as backend, its a GUI frontend.

MATE’s screenshot utility from mate-utils should also support Wayland according to them.

2 Likes

Hello

Thanks for that point about Wayland, interesting that it is not documented by Flameshot itself in the same download section but in other VirtualBox instance I use Ubuntu Desktop 22.04 based on Gnome and Wayland and Flameshot works fine. Therefore the reason is other to have this situation at Fedora

Thanks for the links.

May want to take a look at, Fedora 39 screenshot capture failed · Issue #3340 · flameshot-org/flameshot · GitHub

2 Likes

Thanks for the link Joe!

I use flameshot and it has been a pain to get working for the last 3 Gnome releases. The most recent release broke it pretty bad because of a Portals bug. There are a couple of ways to fix this, including a script, but I did the Portals way which after a restart worked. You also need to have Alt+P for the shortcut to work.

dbus-send --session --print-reply=literal --dest=org.freedesktop.impl.portal.PermissionStore /org/freedesktop/impl/portal/PermissionStore org.freedesktop.impl.portal.PermissionStore.SetPermission string:'screenshot' boolean:true string:'screenshot' string:'flameshot' array:string:'yes'

dbus-send --session --print-reply=literal --dest=org.freedesktop.impl.portal.PermissionStore /org/freedesktop/impl/portal/PermissionStore org.freedesktop.impl.portal.PermissionStore.Lookup string:'screenshot' string:'screenshot'

I’m hoping for a much more accepetble solution, but have not gotten around to finding it. For now this worked.

The Bash script I’ve seen as hit or miss less elegant and clunky IMO :

sudo tee /usr/local/bin/flameshot-workaround > /dev/null <<'EOF'
#!/bin/bash
flameshot

EOF

sudo chmod a+x /usr/local/bin/flameshot-workaround

2 Likes

Huge thanks for your time and support. I will test it soon as I can.

Thank You

It has been a pain for me. I use Screenshots a lot in my workflow, I see Flameshot as a way to not need to open Inkscape to do exactly what I want in a time efficient manner. While I love Inkscape, Arrows, Rectangles, and colored text for simplicity-sake should just be done this simple. Flameshot is it.

Gnome should not be so aggressive in it’s screenshot implementation and Portal use.

Any chance to get Gscreenshot working on Fedora? I’m not able to find it in repository.

Came from KDE and used Spectacle. Installed Fedora 40 Workstation some days ago and Spectacle is not working. It needs KWin Compositor to work, so I’m looking for an alternative.

Spectacle was able to save images in webp format, and I was able to change the path and the name of the files. Gnome screenshot tool has no options to change anything. Looks like Gscreenshot is also able to save files in webp format. So I would like to try that GUI. Any advise?

Why not use GNOMEs default?

Spectacle does have nice editing capabilities, and the recording was also fixed and works awesome.

I dont think a minimalist grim/greenshot will do more than GNOMEs utility

1 Like

Actually, I’m with the default, because no other tool seems to work on Gnome 46 Wayland. But it’s okay … I think I’ll get used to it. Thanks. :slight_smile:

1 Like