First Impressions after upgrading from 38 to 39 with Software

I installed F38 20 days ago from the ISO and took my time customising it. 2 days ago, I was ready to upgrade it to F39, but not before I made a backup with Timeshift and cloned the SSD with dd! I’ve seen a lot of upgrade that went wrong in my 32 years with Linux.

Firstly, I wanted to test the F39 ISO, so I put it in Ventoy: Not booting. Freezing computer. Not a good sign. F38 Gnome and F38 cinnamon ISO worked well since I installed to SSD from them!

2 - Upgraded to F39 with Software. Took an eternity, worked silently, which I hate profoundly, but finally booted on F39 after 2 retries (It froze on the first try). Looked like before with the exception I had no ‘rescue’ option in my grub menu like I used to when I installed F38. A huge disappointment for me because this option already saved my installation when a nvidia driver went so bad that it was impossible to even boot, that thing being frozen in graphics mode with no terminal available!

3 - Tartube was uninstalled by Software for incompatibility.
4 - I opened a ticket with tartube tean to support python 3.12
5 - When I tried to start Kodi (from F39 repo), it crashed on me repeteadly. I need this, I use it on a daily basis.

Enough was enough. An OS that can’t run my regular applications isn’t for me. And I passed the previous 20 days to configure my OS properly, I wasn’t certainly not willing to repeat this. Will wait 3 months and retry the upgrade.

All in all, I saw only bugs, not a single improvement. I use the Cinnamon desktop version installed over the Gnome one. I always hated gnome with its childish icons in its first instance, but its actual Windows 8 look isn’t going to help me like it more.

So I tried to restore to F38 using the Timeshift backup I made prior to the upgrade. Unbootable. Which wasn’t a surprise. Last time I used timeshift to restore was after a nvidia card installation that ruined the system: /etc/shadow files were restored with 000 permissions, and I received some 60 SELinux warnings until I disabled it! Why a piece of garbage like Timeshift skipped out of Mint and make its way into a pretended serious OS like Fedora is absolutely beyond my comprehension. Timeshift will tell you which files are changed, but you can’t read the screen because it reboots in your face. Furthermore it doesn’t have an option to manually remove single files from the restore. The logs aren’t even humanly comprehensible. Lastly, it tells you there have been some errors with perms/ownerships that cannot be restored but is too stupid to tell you which files for you can fix your system manually. What a piece of crap. I expect that from a Windows program, any of them, but never extpected to see that in the Linux word in a lifetime!

So I restored to F38 using my dd image, and back in business again.

Want to upgrade to F39, I’d wait a couple of months if I were you. You’ve been warned.

This doesn’t belong to Proposed Common Issues . Moving to Ask Fedora .

1 Like

Thanks, as you can see I’m new and I struggle to understand this new interface in a foreign language. Much appreciated!

I can’t identify any question the OP has, despite the fact there would be potential solutions for the issues describe.
As is, it doesn’t belong to Ask Fedora, moving to The Water Cooler

Haven’t you read the title? I have no question to ask. I’m reporting how the upgrade went for me.

So far, 2 interventions, none useful.

I’ve been in the linux community for such a long time that I should be used to those participants that have the urge to respond to any new message, even though they have absolutely no solution or nothing else useful to say. Some were even rude. Paul Lutus from AL being the absolute worst. I can’t stand the snobiness existing in the Linux community where the most common answer is RTFM. I’m new here, granted, but I was expecting constructive comments at a bare minimum, not fucking red tape.

I did read the title. Since you don’t have any question to ask, I moved your topic to another category. That’s all.

Moving your topic to another category, does not mean that users won’t comment on it.

1 Like

My experience says it depends on one’s HW.
Just finished Fedora Budgie upgrade from 38 to 39 - took ~20-30 minutes to download and in-place update on Lenovo T495 (AMD). Everything (apps, settings) preserved but the wallpaper :smiley:

Dear Flo,

I don’t see any question there either. I see answers though, and conversation and it 's in the Ask Fedora section.

You are right, I didn’t see that post, and I would not have answered to it, as others did.

Hardware makes sense, particularly with old AMD/Radeon stuff. Remember old versions of linux like 2.2 or 2.4 used to run on 386 25MHz computers. Nowadays one need at least a 2.2GHz CPU clock just to run the GUI.

Thanks!

You wanted a question. The question is why, when 39 started and I logged in,
8 of my desktop icons were greyed out with locks on them. Why?

That never happened on previous upgrades

Me neither, but now when it came to attention I moved it here.

I think the access level is different in the new version