Finish configuration screen after every boot

Hello. I’d like to ask about issue i’m experiencing at every boot of Fedora 36. First i will describe the whole process by word and below will be video:

At first, i simply press power button on my Asus TUF Gaming FX505, when the Grub loads, i will select the most recent kernel version (5.19.12-200.fc36.x86_64). It doesn’t matter as the same issue appears on both kernel versions. Then it boots up to “Finish configuration” screen where i can move mouse for a few seconds. Then the cursor stucks and disappear. Few seconds later it goes black with “nouveau 0000:01:00.0: timer: stalled at ffffffffffffffff” errors. The next line is error about failed to start initial-setup.service. Even after then it boots normal auth screen of KDE.


Right after i log in, 4 same errors appears in issue reporting app:

The whole log of that issue here

PS: Is this caused by the fact i’m using wayland and not x11?

Can you boot to text mode?

  1. interrupt the boot process at the grub screen by typing the Esc key.
  2. Move the highlight to the boot option, usually the first one and press the e key.
  3. In the dialog box, move the cursor to the end of the line that starts with linux
  4. Add a space and then the number 3
  5. Press F10

If you make it to text mode you will be able to

  • put the updates on with sudo dnf upgrade
  • start ssh to log in
  • examine the journal
  • try starting X with xinit or startx

In order to troubleshoot further.

XWayland is started via a compositor, so if you can’t start it with sddm you could try tbsn

Looking at your abrt in the pastebin link

Message: Process 1641 (xdg-desktop-por) of user 988 dumped core.
Executable: /usr/libexec/xdg-desktop-portal-kde

These seem related:

Is this the name of the iso you installed from? Fedora-KDE-Live-x86_64-36-1.5.iso

Can you boot to text mode?

Yep, i could, did the steps you described and it entered the terminal, not GUI. That’s probably what we wanted. Entered the startx and the GUI loaded.

XWayland is started via a compositor, so if you can’t start it with sddm you could try tbsn

Thank you. I probably can start it as i already edited the /etc/sddm.conf to enable always on numlock and the changes applied and did what i wanted. That means (at least to me) it could start by SDDM.

Is this the name of the iso you installed from?

Yep that’s the exactly same ISO.

So it is possible to be related to this specific release?

Since this solved your post can you please click the “solves the problem” button? Thx

I did not solve my issue. We just MIGHT found out that it is a bug.

Did you try to start Wayland from the text console the way that startx starts Xorg? You didn’t mention if you tried tbsn (see link in my old comment above).

You also should check journalctl -b -0 for error message, especially nouveau error messages. If you find any, please pastebin them.

I did solve the finish configuration by disabling that service entirely. Now Fedora just boots up correctly. But i still have those errors afterwards.

Have you tried using the proprietary NVIDIA drivers?

IMHO following that guide is a very poor choice for fedora users.

That guide has the user install the driver directly from nvidia which has 2 drawbacks.

  1. The install is totally manual, and must be repeated with every driver or kernel update since the modules are built specifically for the currently booted kernel and do not work on a different kernel.
  2. Those modules are generic and the user must add and tweak configs for additional features.

If instead you were to install the drivers from rpmfusion following the instructions here and here you would do the install and then forget about updates since a normal system update manages updating the drivers and rebuilding the modules automatically when there is an update to either the driver version or a kernel. The packages from rpmfusion also provide cuda for graphics as well as the tools for proper suspension/hibernation without losing any of the graphics memory at time of shutdown.