File is read-only after booting back into fedora from just having used win10

Hi, I had to boot into windows to do some stuff, after I was done I booted back into fedora. When I tried to open pycharm I get an error about workspace.xml being read-only. I did not even touch pycharm on windows.


How can I make this file non-root accessible?

1 Like
sudo chown "$(id -u):$(id -g)" /path/to/workspace.xml

Nonetheless someone or something has changed the owner/group to root/root.

1 Like

That did not work,

$ sudo chown "$(id -u):$(id -g)" workspace.xml 
chown: changing ownership of 'workspace.xml': Read-only file system

I am not sure why it is saying read-only. It is a ntfs drive. The file is in my MEGA cloud drive too.

I tried to run fsck on the parition to see what was wrong with it, didn’t work either.

$ sudo fsck /dev/sdd2
fsck from util-linux 2.33.2
Unsupported: replay_log()
Unsupported: check_volume()
Checking 97280 MFT records.
Unsupported cases found.
ntfsck was unable to run properly.

As it turns out, I can’t access any part of that drive, not just that one file.

1 Like

Run file system check from Windows and make sure you shut down Windows properly:


Yeah, that worked I just booted into windows and shut down again. Weird thing is I did a clean shutdown too the first time.


@alextrune, it’s a widely known problem with Win8 and Win10 and dualboot (not only with Linux – with MacOS and maybe even with Win7 too). I think (haven’t checked) it’s discussed or pointed to in the links @vgataera gave you.

In short Windows8/10’s fast boot feature doesn’t leave ntfs volumes properly cleanly unmounted on shutdown (but Windows always does fully unmount them on reboot). If you change data from Linux on such a Windows partition in this “unclean” state – you risk loosing your changes or even loosing some Windows’s data that already were there.

In short: make sure to not access Windows partitions in such a state :). It’s recommended to disable fast boot feature in Windows if you’re dualbooting with anything. Also Win10 is known to reenable it – especially after some earlier Windows release upgrades, maybe not anymore – still it’s prudent to check if it’s still disabled from time to time.

1 Like

I did disable fast boot, hopefully it doesn’t come back on its own

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.