Fedore 31 Issue: notebook with lid down and external monitor - screen goes blank, needed to reinstall to 30

This is my first notebook computer, I have two SSDs and dual boot. I had a Fedora 25 install CD got it done, it worked but resolution was off.

I upgraded up to version 30, where I was able to set my 32 inch Viewsonic monitor as the primary and close the lid after boot, and all seemed well.

When I upgraded to Fedora 31 my Display settings must have changed, the screen went blank and I could not reboot. I had to reintstalled Federoa 25 to 30 and have not upgraded since.

There is a trend to use notebook computers, at work and I believe at home. I have a Digital Storm Avon.
I am not sure exactly what happened. I have used Fedora (Redhat) since Redhat 5.0. Tried Linux Mint for a while but does not have rolling upgrades, it’s handling of notebooks is not any better.

What’s the graphic adapter in your notebook?
Generally speaking, upgrading from F25 to F30 in one step is not a good idea. Only skip one release at a time. But it is probably faster and more reliable to download F31 (or F30) right away.
I would try a F31 live environment to see if that works. Did you get a chance to look at the log files after the failed upgrade?
We’re not able to boot at all, none of the kernels?


Geforce RTX 2070 8G
My upgrades were a couple of steps though the Software Update program. Don’t remember how many steps there were, but at first stopped at F30 because I finally got the functionally I wanted with the notebook’s two displays. F31 upgrade then failed. Been using desktop computers for years and never an issue, had only one display.

I tried to reboot system and it failed to give me Grub2 menu, which was very surprising. So I did it all again and am not about to try F31 until I understand what happened. Maybe wait for F32.

The good news is my speakers worked without a problem, unlike Win 10 where I have not been able to get them working, it only uses notebook speakers. After a while one get tired of messing with it. I use Fedora 99% of the time anyway.

Ok, so this is the actual problem: no grub appeared after upgrading from F30 (?) to F31?
Maybe it would be good to edit the title of this thread.

Did you get a chance to look at the log files of the upgrade process? (Sorry, I don’t know where Gnome Software places it’s upgrade logs, I always use dnf. I’m sure someone else can help)

Have you googled if there are known issues with your graphics card and F31.

If the issue is only that grub failed to install, you can boot a live environment, chroot into your F31 Installation and reinstall grub (creating a new grub config). You’ll find many chroot/grub guides online.

Hello florian, thank you for your suggestions.

I just got back into Fedora and Linux, Mint was pretty easy and I didn’t have to trouble shoot much. I Googled F31 video cards issues on my card. It will take some time to go through it. I did try the NVIDIA accelerated driver install, and got an error on reboot about no Kernel support for NVIDIA going back to old Kernel. I rebooted and tried the older kernel, things came backup and I removed NIVIDIA driver.

I’ll have to try a live F31 and work through it from there.

I’m having a similar if not the exact same issue. Running on Fedora 32 with an RTX 2070 mobile GPU using NVidia drivers. Everytime the laptop lid is closed or I switch to single screen mode with the external monitor (connected to the HDMI port) as the selected monitor, the screen just go black and the mouse cursor moves inside it. Keyboard seems to work and I can start (for example) gnome-terminal which just wont’ show on the screen. As soon as I switch back to dual-monitor view, I can see the artifacts and things work normally.

Well, this is weird. It appears as if Microsoft Teams is the culprit. When I have Teams on, the issue happens. (It also seems as if Microsoft Teams is causing issues logging out of Gnome session hanging around). There’s an option in MS Teams settings that talks of using GPU hardware acceleration that might be related to it.