Fedora38 no audio in just one output

Hi, as title suggests, I don’t have audio on one output. I upgraded from fedora 37 to 38 recently, and my line out speakers are no longer working. I’m dual booting, and have confirmed they work fine in the same audio jack in windows 11. So I have confirmed it is not a hardware issue. In fedora 38 audio for headphones connected plugged into the front audio jack works, monitor speakers, through display port, all work fine. It is just the motherboard line out audio. I have plugged in my headphones into the same port in the back and they do not work either.
I updated the bios on my motherboard believing maybe this was an issue. I am running ryzen 5000 series on a b550 mobo if that helps at all. If anyone has guidance on this I’d be grateful. Cheers.

After about 2 hours of troubleshooting I have found the solution. I will post my solution here incase anyone else is having this issue:
Open the terminal and type alsamixer.
You may see many different audio cards, if you have a gpu, onboard audio and other audio devices. Obviously, my issue was with my on-board audio, so I pressed F6 until I skipped all the other audio cards and got to the HD-Audio Generic card:

Using the arrow keys, go right until you have selected the auto-mute button. Press the down arrow to disable auto mute.

And you’re done! I’m not sure why auto-mute is broken for me and I don’t care to find out lol, just glad it works now.