Fedora36 can't connect to 5ghz wifi, only to 2.4ghz

Hi, my 5GHz Wi-Fi is shown in the list but when I try to connect it starts to loading, asks for a password and then nothing. My network card: ASUS PCE-AC68
Fedora is my second system, windows10 connects to 5GHz without any problems.

Welcome to ask :fedora:edora @jac0b

Could you please give us more info’s as :
inxi -Fzx in terminal and post the output as </> Preformatted text here.

If you not had time yet, please also read #start-here

  Kernel: 5.17.13-300.fc36.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.37-27.fc36 Desktop: GNOME v: 42.2
    Distro: Fedora release 36 (Thirty Six)
  Type: Desktop Mobo: ASRock model: B360M Pro4 serial: <superuser required>
    UEFI: American Megatrends v: P1.10 date: 03/07/2018
  Info: 6-core model: Intel Core i5-8400 bits: 64 type: MCP arch: Coffee Lake
    rev: A cache: L1: 384 KiB L2: 1.5 MiB L3: 9 MiB
  Speed (MHz): avg: 3104 high: 3901 min/max: 800/4000 cores: 1: 1356
    2: 3900 3: 3463 4: 3805 5: 2202 6: 3901 bogomips: 33599
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: NVIDIA GP104 [GeForce GTX 1080] vendor: Gigabyte driver: nvidia
    v: 510.68.02 arch: Pascal bus-ID: 02:00.0
  Display: wayland server: X.Org v: with: Xwayland v: 22.1.2
    compositor: gnome-shell driver: X: loaded: nvidia
    unloaded: fbdev,modesetting,vesa gpu: nvidia,nvidia-nvswitch resolution:
    1: 1920x1080~240Hz 2: 1920x1080~144Hz
  OpenGL: renderer: NVIDIA GeForce GTX 1080/PCIe/SSE2
    v: 4.6.0 NVIDIA 510.68.02 direct render: Yes
  Device-1: Intel Cannon Lake PCH cAVS vendor: ASRock driver: snd_hda_intel
    v: kernel bus-ID: 00:1f.3
  Device-2: NVIDIA GP104 High Definition Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel bus-ID: 02:00.1
  Sound Server-1: ALSA v: k5.17.13-300.fc36.x86_64 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.51 running: yes
  Device-1: Intel Ethernet I219-V vendor: ASRock driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6
  IF: eno1 state: down mac: <filter>
  Device-2: Broadcom BCM4360 802.11ac Wireless Network Adapter
    vendor: ASUSTeK driver: wl v: kernel bus-ID: 01:00.0
  IF: wlp1s0 state: up mac: <filter>
  Device-1: ASUSTek Broadcom BCM20702A0 Bluetooth type: USB driver: btusb
    v: 0.8 bus-ID: 1-10:4
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
  Hardware-1: Intel SATA Controller [RAID mode] driver: ahci v: 3.0
    bus-ID: 00:17.0
  Local Storage: total: 1.13 TiB used: 10.95 GiB (0.9%)
  ID-1: /dev/sda vendor: GOODRAM model: IR SSDPR S25A 240 size: 223.57 GiB
  ID-2: /dev/sdb vendor: Toshiba model: HDWD110 size: 931.51 GiB
  ID-1: / size: 144.9 GiB used: 10.7 GiB (7.4%) fs: btrfs dev: /dev/sdb5
  ID-2: /boot size: 973.4 MiB used: 239.3 MiB (24.6%) fs: ext4
    dev: /dev/sdb4
  ID-3: /boot/efi size: 598.8 MiB used: 13.9 MiB (2.3%) fs: vfat
    dev: /dev/sdb3
  ID-4: /home size: 144.9 GiB used: 10.7 GiB (7.4%) fs: btrfs
    dev: /dev/sdb5
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) dev: /dev/zram0
  System Temperatures: cpu: 34.0 C pch: 42.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 346 Uptime: 3m Memory: 15.45 GiB used: 2.49 GiB (16.1%)
  Init: systemd runlevel: 5 Compilers: gcc: 12.1.1 Packages: 6
  note: see --pkg Shell: Bash v: 5.1.16 inxi: 3.3.16

may want to check, Bug #1574196 “Card with chipset BCM4360 [14e4:43a0] (rev 03) do...” : Bugs : bcmwl package : Ubuntu


1 Like

The wl driver is not included with Fedora kernel. You seem to be using an out-of-tree module, which is not supported by Fedora. You failed to mention that. Your Wi-Fi chip might be supported by the brcmfmac driver. Try uninstalling broadcom-wl and akmod-wl packages (assuming you got the wl driver from RPM Fusion) and rebooting and see if Wi-Fi networking works then.

I removed broadcom-wl and akmod-wl, now there is no option Wi-Fi in settings(just disappeared).
How can I install this brcmfmac driver?