Fedora won't boot anymore, No desktop KDE after update

I’m using Fedora 33 Kde spin. This morning I updated my system with sudo dnf update. Dnf installed 8-10 packages (don’t remember names except ssdm), than I powered off my system. Thirty minutes ago I powered on my desktop but, after grub, it won’t boot anymore! I can only see, after grub selection, the Fedora logo for about 5-6 seconds, than a black screen appears.

This happens with all three boot options (5.10.9-201.fc33, 5.10.8-200.fc33, 5.10.7-200.fc33). What’s wrong and how to resolve it?

I’m sure it’s not an hardware failure because I’m writing this post with a bootable usb drive with Kubuntu 20.04 connected to the same desktop.

Please help me, thanks.

ps. I’m not using a dedicated graphic card: I use the integrated chip in my Intel i5-6600 cpu

pps. Do you think it’s related to sddm update? Here is the Xorg.1.log:
[ 22408.303] (EE) Failed to open authorization file "/var/run/sddm/{d719c9f1-35a0-4f30-b0b4-582d940655b9}": No such file or directory

1 Like

I think a found a critical Fedora bug introduced with the latest sddm updated by Fedora Plasma teams.

I found a workaround:

  1. Enter Grub, than press “e”
  2. Look for the line that begins with linux …vmlinuz: at the end of the line add “3” (for example
    kernel /vmlinuz […] quiet 3
  3. Press F10: the system loads.
  4. At the login screen enter username and password
  5. (Now we have to replace SDDM with GDM). Enter these commands:
sudo dnf instal gdm -y
sudo systemctl disable  sddm --now
sudo systemctl enable gdm --now
  1. At this point the GUI login screen appears. Enter you username and password but don’t press enter. You have to change Plasma (X11) in DE selection. Now you can enter your Plasma session.

Yep, good workaround and catch, it will reported in redhat bugzilla:


Could you please comment in this bug your workaround? you can login with your FAS account… there.

I also mark your answer as solved…


1 Like

Unfortunately the above solution still doesn’t work for me.

I’m running Fedora 33 on a VMWare Workstation 16 on a Windows 10 PC.

When I log in I get a ksplashqml (The KDE Crash Handler) error message, and a couple xterm windows but no Plasma background or taskbar. The xterms enable the machine to function, but this all occurred as the result of a recent (Jan. 27?) dnf update. At the time my first indication of a problem was when I was unable to logout using the KDE’s “Leave” option, and had to resort to a “sudo shutdown”.

I’ve tried upgrading to sddm-0.19.0-5 (as per 1919696 – Fedora Kde Plasma spin won't boot anymore after latest sddm update), but no luck there. I’ve also tried removing ~/.cache but no luck.

I also experimented by installing a completely fresh version of Fedora 33 using VMWare Workstation (followed by “sudo dnf install kde”, and then choosing kde (Plasma) during login). But I got the same ksplashqml error screen and no Plasma background/toolbar. Is there somewhere else we can report to the Fedora33 developers that KDE doesn’t work “fresh out of the box” anymore? Thanks.

1 Like

Yestarday I updated my F33, everything’s goes fine until today boot. After yesterdays update I didn’t restart my notebook. Today I run notebook with 5.10.9-200 kernel. I see Fedora is loading/spinning after it ends I see cursor (not blinking) on top left corner, kde mouse pointer appears for second and gone. I tried to boot to 5.10.8-200, 5.10.7-200 with same result as above. I can switch to tty with ctrl+alt+F2. After switch back to F1 I see mouse pointer I can move it but screen is black. In text only mode I don’t have network connection because I tried to run update. What should I check to resolve my problem?

I found similar problem to my. Fedora won't boot anymore but in xorg log I didn’t find ‘failed to open authorization file’ but in journalctl I found that after start sddm there is log that ‘Auth: sddm-helper exited with 1’
Now I am trying to extend logging of sddm.

Thaths journalctl log Journalctl - Pastebin.com I can not find any plausible reason of problems for sddm


Yes, very likely it’s the same bug: 1919696 – Fedora Kde Plasma spin won't boot anymore after latest sddm update

I don’t know how Fedora Kde team introduced this bug.


My temporary solution until @sbaragnaus posted bug would be fixed is:

  1. Switch to TTY using Ctrl+Alt+F2
  2. As root execute: dnf downgrade sddm and systemctl restart sddm

Bugs don’t always affect all systems. It went through the QA process, and as you see here, it worked for people who gave it positive feedback, allowing it to be pushed as an update.


You can prevent such cases from slipping through by helping the KDE team (and package maintainers in general) by testing these updates and providing karma:


You can start now: A new update has been pushed that should fix the bug:



Please advice where is the right place to report issues in rawhide nightly builds? Or nightly builds in general?

That’s the QA team. If you are using Rawhide, you should really bookmark this link :slight_smile:

1 Like
bodhi updates download --updateid FEDORA-2021-b71b8a85c8
sudo dnf install sddm-0.19.0-4.fc33.x86_64.rpm
sudo dnf install sddm-themes-0.19.0-4.fc33.noarch.rpm

(reboot in terminal mode)

sudo systemctl disable gdm --now
sudo systemctl enable sddm --now

It doesn’t boot. :neutral_face:

(reboot in terminal mode)

sudo systemctl disable sddm --now
sudo systemctl enable gdm --now

The new update didn’t solved the bug. I’ll give a negative karma to the update.


Sounds good. Did you give it karma? I still see it at 0 karma.

Fixed in sddm-0.19.0-5.fc33.

Not fixed for me and the workaround doesn’t help.

If it’s not fixed for you please make a note in the bug report: 1919696 – Fedora Kde Plasma spin won't boot anymore after latest sddm update


1 Like

There seems to be at least two separate issues. There is/was an sddm issue.

There is also an unresolved issue with graphics that isn’t clear what it impacts. Under vmware, disabling 3d acceleration on the VM seems to be a workaround for the second issue.


disabling 3d acceleration on the VM seems to be a workaround

It helps, but it’s not a solution. :disappointed:

1 Like

Not fixed as I just did a fresh F33 KDE install on a vm, did an update via terminal and got a blank screen after reboot. The workaround on post#2 works for now.

Fedora 33 KDE , 5.10.16-200.fc33

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.