Fedora won't boot after installing updates - without rebooting with power button

I have encountered an issue with fedora 40 and gnome 46. When I “Install pending updates” the system installs them, but won’t boot until I force restart it with the power button once the updates are finished. It simply gets stuck on the boot screen, with the loading wheel not even moving. I am also dual booting windows 11, and have an nvidia gtx 1060.

Any help would be greatly appreciated.

We need more information in order to help:

  • Are you installing updates from the command-line or using Gnome Software GUI?
  • Do you have Nvidia dGPU? If so, how did you install the Nvidia driver: rpmfusion, directly from Nvidia, or one of the 3rd party repos? Do you also have an iGPU?

It is often helpful to have the output from running inxi -Fzxx in a terminal (post as pre-formatted text using the </> button from the top line of the text entry panel). This helps us solve your issue and is also easily discovered with web searches by others with similar hardware and issues.

I am triggering the updates by restarting with the gnome restart button, and ticking “Install pending updates.” So yes, it is from gnome software. I installed the nvidia driver by using rpm fusion, with the command: “sudo dnf install nvidia-driver”
This is the output from inxi -Fzxx

System:
  Kernel: 6.9.4-200.fc40.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.41-37.fc40
  Desktop: GNOME v: 46.2 tk: GTK v: 3.24.42 wm: gnome-shell dm: GDM
    Distro: Fedora Linux 40 (Workstation Edition)
Machine:
  Type: Desktop Mobo: ASUSTeK model: PRIME X470-PRO v: Rev X.0x
    serial: <superuser required> part-nu: SKU UEFI: American Megatrends v: 4602
    date: 03/07/2019
CPU:
  Info: 6-core model: AMD Ryzen 5 2600 bits: 64 type: MT MCP arch: Zen+ rev: 2
    cache: L1: 576 KiB L2: 3 MiB L3: 16 MiB
  Speed (MHz): avg: 1853 high: 3400 min/max: 1550/3400 boost: enabled cores:
    1: 1431 2: 1550 3: 2302 4: 1550 5: 1357 6: 1513 7: 2068 8: 3400 9: 2800
    10: 1375 11: 1343 12: 1550 bogomips: 81433
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Graphics:
  Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] vendor: eVga.com.
    driver: nvidia v: 550.90.07 arch: Pascal pcie: speed: 2.5 GT/s lanes: 16
    ports: active: none off: DP-1 empty: DP-2, DP-3, DVI-D-1, HDMI-A-1
    bus-ID: 09:00.0 chip-ID: 10de:1c03
  Device-2: Logitech Webcam C310 driver: snd-usb-audio,uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 bus-ID: 3-1:2 chip-ID: 046d:081b
  Display: x11 server: X.Org v: 1.20.14 with: Xwayland v: 24.1.0
    compositor: gnome-shell driver: X: loaded: nvidia unloaded: modesetting
    alternate: fbdev,nouveau,nv,vesa gpu: nvidia,nvidia-nvswitch
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96
  Monitor-1: DP-1 note: disabled model: Samsung S22F350 res: 1920x1080
    dpi: 102 diag: 547mm (21.5")
  API: OpenGL v: 4.6.0 vendor: nvidia v: 550.90.07 glx-v: 1.4
    direct-render: yes renderer: NVIDIA GeForce GTX 1060 6GB/PCIe/SSE2
  API: EGL Message: EGL data requires eglinfo. Check --recommends.
Audio:
  Device-1: NVIDIA GP106 High Definition Audio vendor: eVga.com.
    driver: snd_hda_intel v: kernel pcie: speed: 8 GT/s lanes: 16
    bus-ID: 09:00.1 chip-ID: 10de:10f1
  Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel
    v: kernel pcie: speed: 8 GT/s lanes: 16 bus-ID: 0b:00.3 chip-ID: 1022:1457
  Device-3: Logitech Webcam C310 driver: snd-usb-audio,uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 bus-ID: 3-1:2 chip-ID: 046d:081b
  API: ALSA v: k6.9.4-200.fc40.x86_64 status: kernel-api
  Server-1: JACK v: 1.9.22 status: off
  Server-2: PipeWire v: 1.0.7 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
Network:
  Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: kernel
    pcie: speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 07:00.0 chip-ID: 8086:1539
  IF: enp7s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  IF-ID-1: virbr0 state: down mac: <filter>
Drives:
  Local Storage: total: 1.36 TiB used: 199.23 GiB (14.3%)
  ID-1: /dev/nvme0n1 vendor: Crucial model: CT1000P2SSD8 size: 931.51 GiB
    speed: 31.6 Gb/s lanes: 4 serial: <filter> temp: 46.9 C
  ID-2: /dev/nvme1n1 vendor: Samsung model: SSD 970 EVO Plus 500GB
    size: 465.76 GiB speed: 31.6 Gb/s lanes: 4 serial: <filter> temp: 40.9 C
Partition:
  ID-1: / size: 382.43 GiB used: 36.04 GiB (9.4%) fs: ext4 dev: /dev/nvme0n1p4
  ID-2: /boot/efi size: 1022 MiB used: 19 MiB (1.9%) fs: vfat
    dev: /dev/nvme0n1p2
  ID-3: /home size: 511.81 GiB used: 163.18 GiB (31.9%) fs: ext4
    dev: /dev/nvme0n1p3
Swap:
  ID-1: swap-1 type: zram size: 8 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  ID-2: swap-2 type: partition size: 19.82 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p1
Sensors:
  System Temperatures: cpu: 40.0 C mobo: 42.0 C gpu: nvidia temp: 45 C
  Fan Speeds (rpm): cpu: 920 case-1: 1173 case-2: 0 case-3: 0 gpu: nvidia
    fan: 0%
  Power: 12v: 10.14 5v: N/A 3.3v: N/A vbat: N/A
Info:
  Memory: total: 16 GiB available: 15.54 GiB used: 6.83 GiB (43.9%)
  Processes: 470 Power: uptime: 1h 51m wakeups: 0 Init: systemd v: 255
    target: graphical (5) default: graphical
  Packages: pm: flatpak pkgs: 51 Compilers: gcc: 14.1.1 Shell: Bash
    v: 5.2.26 running-in: gnome-terminal inxi: 3.3.34

This is not the command used to install the driver from rpmfusion. That would have been sudo dnf install akmod-nvidia as is shown here.
https://rpmfusion.org/Howto/NVIDIA

Please post the output of dnf list installed \*nvidia\* so we can see what is installed and where it was installed from.

Installed Packages
akmod-nvidia.x86_64                       3:550.90.07-1.fc40 @rpmfusion-nonfree-nvidia-driver
kmod-nvidia-6.8.10-300.fc40.x86_64.x86_64 3:550.78-1.fc40    @@commandline                   
kmod-nvidia-6.8.11-300.fc40.x86_64.x86_64 3:550.78-1.fc40    @@commandline                   
kmod-nvidia-6.9.4-200.fc40.x86_64.x86_64  3:550.90.07-1.fc40 @@commandline                   
nvidia-gpu-firmware.noarch                20240610-1.fc40    @updates                        
nvidia-modprobe.x86_64                    3:550.90.07-1.fc40 @rpmfusion-nonfree-nvidia-driver
nvidia-persistenced.x86_64                3:550.90.07-1.fc40 @rpmfusion-nonfree-nvidia-driver
nvidia-settings.x86_64                    3:550.90.07-1.fc40 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia.x86_64                3:550.90.07-1.fc40 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-cuda.x86_64           3:550.90.07-1.fc40 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-cuda-libs.x86_64      3:550.90.07-1.fc40 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-kmodsrc.x86_64        3:550.90.07-1.fc40 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-libs.x86_64           3:550.90.07-1.fc40 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-power.x86_64          3:550.90.07-1.fc40 @rpmfusion-nonfree-nvidia-driver

Try this, just in case the last update did not complete properly.

sudo dnf remove kmod-nvidia-6.9.4-200.fc40.x86_64
sudo akmods --force --kernels 6.9.4-200.fc40.x86_64

Following the completion of the akmods command reboot with kernel 6.9.4 and see if it now works.

Still causes the same issue, however instead of the progress wheel freezing, it just becomes a black screen. I updated by pressing “Update and Restart” in gnome software.

Those commands I gave are for use in a terminal.
Using the “update and restart” in gnome software can (and sometimes does) cause the system to reboot before the kernel modules for the gpu are properly built and installed.

Those commands allow user control of when the system is rebooted and ensure a proper build of the driver modules before the reboot occurs. Doing that on the command line is usually successful in recovery from corrupted driver modules.

I personally have never had an issue with the nvidia drivers since I always use dnf on the command line to perform updates and never depend upon the timing within the gnome software gui for updates and rebooting

Note also that since the kernel has now been upgraded to the 6.9.5 version in fedora the command given does not apply to the latest kernel. It may need to be repeated using the 6.9.5 kernel in both commands instead of the 6.9.4 kernel shown in my post above.

Ngl I am starting to consider removing gnome software - due to the problems it’s causing.
Is it safe to remove it? Or will it break my system?

You should not blame Gnome for Nvidia policies that force complex and error prone workarounds (that often require use of the linux command line) to install Nvidia drivers. Changing desktops doesn’t change the steps needed to ensure Nvidia drivers are properly installed.

1 Like

It’s easy to blame nvidia but I doubt this issue was caused by them.
The latest plymouth update is known to be broken.

https://bugzilla.redhat.com/show_bug.cgi?id=2274770

Just to clarify, I meant remove the “gnome software” app, not the entire gnome desktop environment.

you can’t remove gnome-software, but you can disable the backend service that is powering Gnome Software.

sudo systemctl stop packagekit.service
sudo systemctl disable packagekit.service
sudo systemctl mask packagekit.service

sudo systemctl stop packagekit-offline-update.service
sudo systemctl disable packagekit-offline-update.service
sudo systemctl mask packgekit-offline-update.service
1 Like

Don’t try that complex issue.
Simply do not use it and it will have the same effect. If not used it cannot cause problems.

Ok, I disabled automatic updates on gnome software, and will use terminal to update from now on. Hopefully that will fix it.