Fedora Upgrade with RedHat Satellite


I’m trying to perform an upgrade from Fedora 30 to 31 like described in the docs: DNF System Upgrade :: Fedora Docs
I tested it with a machine with Internet access, where it worked fine, but I have to do this with our local repositories from the RedHat Satellite.
So the first question/step is: How can I configure/tell dnf to use the local repositories also for the system-upgrade download step?
Or another formulation for the question: How does the --releasever=31 switch knows where it has to look for the files?

dnf system-upgrade download --releasever=31

Thanks beforehand for your help.


Hi @ntchen, welcome to ask.fedora!

Or another formulation for the question: How does the --releasever=31 switch knows where it has to look for the files?

releasever is just a variable used by dnf in the repo definition. It is used in the repo URL definition or in the metalink definition. Here is the metalink definition from my machine:


So if I am not mistaken, you need to provide the repository of release 31 via your Satellite, and make sure that the repo URL definition on your machines is not hardcoded to the current release.

Does that make sense?


Hi @liquidat,

thank you very much for your post. In my opinion your idea does make sense - the Fedora version is hardcoded in the .repo-files on my machines, I have to look how I can change that the correct way. In any way this this a good place to start.

Thanks once more, I will report if I can tell something new.


1 Like

Glad that I could help. Please feel free to mark the post as solution to help others who are struggling with the same problem.

And let me know if you were able to fix it.

Hello again,

i marked your answer as solution for my second question-formulation. As i said, the URL to the repositories are “hardcoded” in my case and a test with the added $releasever variable resulted in the expected outcome like you described it.
However, the solution to get the upgrade to work was even easier. I simply added the fedora31 repositories additionally to my .repo-files (via new RedHat-Satellite-Activation-key and subscription-manager) and “dnf system-upgrade download --releasever=31” worked as expected.

Thanks once more for your help.



Interesting and good to know. Thanks for sharing!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.