Fedora Upgrade to 39 Failed


my upgrade from Fedora 38 to Fedora 39 didn’t work

/etc/fedora-release shows 38 for me. i tried downloading in Software, but it failed. tried doing it in terminal but got the message that there was nothing to do.

also get this error message in this screen shot -
Screenshot from 2023-11-10 00-17-22

i tried looking for that package but couldn’t find it. not sure if i’m just not looking in the right spot.

I think you have 3rd party repos defined that are causing the problem.
May be related to this topic DNF update problem

if i’m reading this correctly, the installation i did of pgAdmin4’s repo is what’s causing the issue, right? if i remove it and go with what’s already in Fedora’s repos, i’ll need to redo the connection to the database that i’m currently using, correct? that may be a dumb question.
i ask because i’m currently taking courses on SQL, so i’m still pretty new to it. it was difficult enough connecting the database to pgAdmin anyway, just would like to avoid going through that again if i can help it. but i guess it would be a good learning exercise.

Yes it is the pgAdmin4’s repo that broke your system.

Unless you have a strong reason using postgresql from the fedora repos sill avoid issues.

Are you using the same version of postgresql that fedora will install?
If not you need to check how to migrate the db.

i feel like the answer to your question is no - i downloaded it from their website. i think i did that because i couldn’t find it in Software when i searched for it, so i thought that would be the correct approach. i think i could probably easily set up the database again for the course - it’s not that big of a database, and it’s pretty basic, i think.
would i just need to remove pgadmin and re-install through the terminal? to get the one in fedora’s repo?

You can dump your existing postgres db and then load the dump into the new version.
The dump format is SQL commands.
pg_dump is the tool to use I believe PostgreSQL: Documentation: 16: pg_dump

After that you can dnf remove all the postgres RPMs that you installed.
Then the system-upgrade should work.

I also used the command line upgrade procedure as a personal choice.
Makes it easy to capture error messages in case of problems.
The process to follow is here Upgrading Fedora Using DNF System Plugin :: Fedora Docs

thanks for the information, Barry :pray: very much appreciated!

(post deleted by author)

(post deleted by author)