Fedora silverblue install break

I even created a second EFI and did the manual install = again the same error!

Hi nazar2sfive and welcome to the forum!

I believe you are missing an ext4 /boot partition.

The ‘Auto’ option creates a separate /boot partition but not sure if it is needed. A separate /boot may not be needed if you do not choose LVM or if you create an LV for ‘boot’.

Following are my experience (the installation had failed on me too).

  1. Fedora needs a separate EFI partition.
  2. On Macs it needs to be formatted as ‘Linux HFS+ EFI’ not as ‘EFI System Partition’
  3. As suggested by DorianDotSlash in one of his YouTube video, the ‘trick’ is to remove ‘esp’ flag from the EFI partition. This may be the case why it doesn’t work with EFI partition of other OS ( :point_up_2: 1). You can do it from Gparted; right click EFI partition, choose ‘Manage flags’ and remove ‘esp’. I cannot confirm this method because on Macs it fails (:point_up_2: 2)

That said, once we delete a partition (or reclaim the space) and have sufficient free space for install, I found it easy to just select first option (Click here to create them automatically) where it offers to auto create mountpoints, instead of manually creating mountpoints further.

1 Like