Fedora/Nobara 39 KDE : circumflex and diaeresis accents

Hi all,

I cannot write any voyel with a diaeresis or a circumflex accent. Usually, in French, you press the ^key, then the voyel key, and you get a voyel with an accent, like û.
When I do it, i only get an accent, followed by a voyel, like ^u.

Here is my keybord setup:

clement@nobara-pc:~$ localectl status
System Locale: LANG=fr_FR.utf8
    VC Keymap: fr
   X11 Layout: fr
    X11 Model: pc105
  X11 Options: terminate:ctrl_alt_bksp

I have changed the keyboard layout, I have changed the language to fr_BE.UTF-8, to en_GB.UTF-8… it doesn’t solve the problem. Everything else on my keyboard works perfectly.

I can’t find answers on Fedora docs. Thank you very much for your help!

What exact keyboard layout? Some layouts have dead keys, which you seem to want, and some have no dead keys. The default french keyboard layout do have dead keys, where when you type in “^” and “a” “a” with circonflex. That is how it would work in X11, but your environment may be different. I assume that if you changed the layout with the localectl utility, you have logged out and logged in again to have the keyboard change take effect.

I also assume that KDB has its own setting for keyboard mapping, which you should check.

1 Like

Hi!

Yes, your idea was good! I tried many different keyboard layouts, but I never logged out after each try.
I did it and now it works perfectly.

Sorry for my stupid question and thanks a lot for your help!

It is not stupid, just a learning opportunity.