Fedora live/USB installer booting with my own corrupted kernel

I had a fedora partition with Fedora 29, but,
Fedora’s upgrade into a newer version got interrupted half past completion, therefore, breaking the distro. Other kernels, supposedly safe rescues kernels, don’t work as well.
So I’ve used ventoy to install a new fedora .iso in a flash drive.
But for some reason both grub/grub2 are, apparently, using my own broken kernel? The output is the same “kernel panic” terminal boot error.
Rufus seems like to present the same output, as if the system required my own machine’s booting config unlike the previous fedora installer (tested on the same day before wiping the older version of fedora installed on it) which booted fine. Windows 7 partition also works fine.

I’ve tried with Fedora 37/36 workstation/everything-netinstall.
I tried to troubleshoot, and all options prompt the kernel with the output error.

Welcome Markegi to ask :fedora:

I am sorry to hear about the boot issues, however i think you are misunderstanding what is happening.

When booting from an iso image, whether by using ventoy or using an image that has been written to a usb device directly it does not use the installed OS in any way, but only what is on the usb device.

Please provide some information about your system.
I understand that you had a working version of fedora 29. Was that a 32 bit version or 64 bit version?
Is your system capable of booting a 64 bit operating system? If not then you will not be able to install the newer fedora since (I think) Fedora 33 was the last version of fedora that had a 32 bit kernel available and newer versions are 64 bit only.

If your system is 32 bit only there are linux distros that still support 32 bit systems, but fedora is not one of those.

We will be waiting to hear back on the hardware involved to know if we are able to move forward in solving this issue.


I am on a 64 bits windows 7, windows task shows some softare runing with a *32 and others are not, on proprieties of system it shows a ‘64 system type’. But interesting enough I’ve seen your point working to at least try fedora 27/29, and they booted. But after forwarding the installer’s language, they prompted a bug which I could’ve pasted here. Re-trying another distro install really pisses me off.
The fedora 27 still shows my windows partition with only 8gb free, while it has hundreds of free space. The reason for trying newer versions was to see if I could recreate partitions with better installers recognizing the free space, but in the end they were all very coherent with the kernel’s panic since the oldest kernel was Fedora 31, already a 64bit-only which could explain the error. And for the 8gb/100gb+ I don’t think it matters anymore.

So I don’t know now if it’s something about Fedora incompatibility with my 64-bit hardware. Perhaps Fedora isn’t just for me then if I can’t upgrade it further.

With F27/29 you are quite behind. It changed a lot since. If you want to test you have just to use the live iso writing to a pen-drive. If you can boot and use it, you can also install it. Make a backup of your home drive and wipe the data. The installer will reuse the space and use btrfs as the default filesystem.

You might just show us the error.
And do a inxi -Fzx in terminal and post the output here. So we can see what system you have.

Note that AFAIK windows 7 was only installed in legacy (MBR) mode. Installing fedora must be done with the same boot mode if you wish to be able to boot both systems from the fedora grub menu. This means simply that you boot the install image as legacy boot and it installs in that mode.

I’ve successfully installed Fedora 30, and by the time the system asked to update, from kernel 5 to 5.6, it showed the constant debug ‘kernel panic’ I had with the prior distro, now Kernel 5.6 but still as Fedora Thirty. The whole coincidence was the power interruption, I guess.
Funnily enough I’ve checked on Fedora 30 before updating the kernel and the system prompted ‘64-bits’ so I really don’t know what’s happening but I believe @computersavvy was right to point incompatibility with the newest version.

I’ve tried Debian i386 but it can’t boot, ubuntu 22 also can’t boot.
lscpu showed 64bits “36 bits physical, 48 bits virtual”, it’s an intel amd64.

The only distro working is Fedora 30 backwards, even that it only started presenting problems after the kernel update and not the OS. Booting by the oldest kernel+fedora 30 still works, but not the kerl 5.6+
Anyone could help me to what procedure take from here?

If you can boot it then please post the output of inxi -Fzxx as Preformatted Text using the </> button so we can see the hardware details.

This may also be affected by the bios version and motherboard if they are too old to support the newer and more demanding kernels.

@ilikelinux @computersavvy

System:    Kernel: 5.0.9-301.fc30.x86_64 x86_64 bits: 64 compiler: gcc v: 9.0.1 Desktop: GNOME 3.36.9 tk: GTK 3.24.28 
           wm: gnome-shell dm: GDM Distro: Fedora release 32 (Thirty Two) 

Info:      Processes: 238 Uptime: 4m Memory: 7.78 GiB used: 1.64 GiB (21.1%) Init: systemd v: 245 runlevel: 5 
           target: graphical.target Compilers: gcc: 10.3.1 Packages: rpm: 1738 Shell: Bash v: 5.0.17 
           running-in: gnome-terminal inxi: 3.3.03 

System:    Kernel: 5.0.9-301.fc30.x86_64 x86_64 bits: 64 compiler: gcc v: 9.0.1 Desktop: GNOME 3.36.9 tk: GTK 3.24.28 
           wm: gnome-shell dm: GDM Distro: Fedora release 32 (Thirty Two) 
Machine:   Type: Desktop System: POSITIVO product: : 1.0 serial: <filter> 
           Mobo: Positivo Informatica SA model: : 1.0 serial: <filter> 
           BIOS: Desenvolvida para Positivo Informatica SA v: X date: X
CPU:       Info: Dual Core model: Intel Core i5 650 bits: 64 type: MT MCP arch: Nehalem rev: 5 cache: L2: 4 MiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 25599 
           Speed: 1466 MHz min/max: 1200/3201 MHz boost: enabled Core speeds (MHz): 1: 1466 2: 1467 3: 1467 4: 1466 

PU:       Info: Dual Core model: Intel Core i5 650 bits: 64 type: MT MCP arch: Nehalem rev: 5 cache: L2: 4 MiB 
           bogomips: 25599 
           Speed: 1288 MHz min/max: 1200/3201 MHz boost: enabled Core speeds (MHz): 1: 1288 2: 1396 3: 1222 4: 1428 
           Flags: acpi aes aperfmperf apic arat arch_perfmon bts clflush cmov constant_tsc cpuid cx16 cx8 de ds_cpl dtes64 
           dtherm dts ept est flexpriority flush_l1d fpu fxsr ht ibpb ibrs ida lahf_lm lm mca mce mmx monitor msr mtrr 
           nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pebs pge pni popcnt pse pse36 pti rdtscp rep_good sep smx ss 
           ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc vme vmx vnmi vpid xtopology xtpr

I took the liberty of editing your post and added the Preformatted text tags that were requested so it shows the same as originally on your screen.

Only a portion of the output from inxi was posted so we cannot see the full details. A critical item that is missing is the amount of RAM installed.

I can see that the system is at least 10 years old based on the motherboard information and the processor model. With that information I would venture that the hardware may not be capable of supporting the newer kernels, though you might be able to upgrade to a much newer version of fedora if you were to do so gradually,

Using the dnf system-upgrade path, and upgrading one version at a time might be possible by following the steps here. I cannot tell what may or may not work, but if the system is not able to install and boot a newer kernel when doing sudo dnf upgrade then it seems not likely to be able to upgrade the fedora release version. This failure might be overcome by ensuring that you have at least 4 GB RAM installed.

With the age of your system I would suggest that you consider newer hardware, though many are able to use the older hardware within limitations.

The full output of inxi -Fzxx would really be helpful.

1 Like

There is also an LTS kernel if you want to try this:

kwizart/kernel-longterm-5.15 Copr

Maybe this could be the Intel integrated graphics in conflict with the Nvidia GPU?
I’ve tried messing with the BIOS intel VT, intel HT etc. and I could even boot a late kernel in fedora 37, but, a single update prompted kernel panics again.

Now a simple Fedora 29 with 5.3 kernel (netinstall) gives kernel panics.

I’ve tried multiple distros, and all of them seem that could boot on kernels older than the 5. But the booting issue started with the fedora upgrade.

You can use Linux Hardware to see which kernels work with your hardware. If your system uses hardware graphics or other expansion cards you can check to see if they work with recent kernels.

Check for BIOS updates. Some vendors have community forums where you may find BIOS settings needed for recent linux kernels. You should also check to see if your system can run Windows 10. I had an early core i7 system that was dual booting Windows 10 and Fedora 38 until the graphics card died (leaving we without legacy firewire and memory card support).

Businesses have been dumping systems 3–4 years old that don’t support Windows 11
You might find it better use of your time to replace your system with a “refurbished” system 2–3 years old that has good linux support (per the Linux Hardware site).