Fedora Linux is awfully slow on Dell Inspiron

Hello, I have an old Dell laptop, Dell Inspiron N5050. It has an Intel® Core™ i3-2330M model processor. I wanted to give it a life back with Fedora (37, Gnome), although as I know, Fedora likes new hardware. I upgraded it with SSD and installed 12 GB of RAM. But still, it’s awfully slow. Also, it has WI-FI issues because of Broadcom driver. I installed broadcom-wl and after that, my home WI-FI just disappeared. When I uninstall broadcom-wl, my home WI-FI appears and connects, but the connection is so slow. Anyway, WI-FI is not my main concern, I have an external Wireless adapter. What can cause this terrible performance issue? Maybe CPU is dead? (I cleaned and replaced thermal paste).

Can you quantify what is slow and how slow it is?

i3 is a low-end CPU that prioritizes low cost and battery life over performance. Additionally, that CPU came out 12 years ago. Software can be more efficient, but it can’t transform a 200K inline 4 into a new V8.

1 Like

Just opening a tab in Chrome, watching some stuff etc. Opening settings takes 7–8 seconds.

Fair point, but is this CPU this bad? Can’t even handle a single Chrome tab.

That seems too slow to me, even on an older CPU.

  • Did you try both X11 and Wayland?
  • Anything interesting in the logs?
  • Are there any processes consuming a lot of cpu or i/o?

There’s no any processes, I freshly installed the OS twice. I tried only Wayland. Nothing interested, just got kernel-core error one time without any description.

What did you use to check?

Can you try testing X11 to see if there is any difference? You just have to select an X session from the login screen.

I don’t expect major desktops like GNOME or KDE to work well on such old hardware, I suggest something much lighter like XFCE or fluxbox.

I have a very old device with an Intel Pentium M (1.7 GHz, 2006 model=16 years old) and it is usable with fluxbox and antiX Linux.

So I recommend a lighter DE or a lightweight distro like MX Linux or antiX.

1 Like

I really didn’t use anything to check, because as I said, it’s a freshly installed system and I installed only Chrome and some Gnome extensions.

I will try X11 and post the result when I get home. Thanks.

That doesn’t mean anything. Even on a freshly installed system there are dozens of processes running.

Okay, but aren’t them default processes for the system to operate?

Probably. But the question isn’t “Which processes are running?”. The question is “Are any of those processes consuming a lot of resources?”

Debugging performance issues is a bit like detective work.

1 Like

I will check the processes and post the result. Thanks.

1 Like

A newly installed system can easily have 200+ processes active. The fact it is newly installed does not truly define the number of active processes. In fact you might be surprised at the result of ps aux | wc -l. I have 3 different systems that I keep active and all return 300+ as the output of that command.

Modern web is very CPU intensive. If that “one tab” is something like Facebook or GMail, then yeah, that might be the case. GMail struggles to fully load on a quad-core raspberry pi 4. Much of the modern web pushes javascript to do client side computing and much of that javascript is poorly written and inefficient and the reason that most sites get away with it is that most people are using newer and beefier CPUs than what you’re currently running. If you can somehow trick the websites into running the mobile versions, you might have better luck with that CPU?

1 Like

I have a older Dell Inspiron also that I was trying to install Fedora 38 fresh, and I see the exact same behavior. The CPU and the Memory are rather idle, … it just extremely slow either way with a fresh install. This didn’t happen in Fedora 36.

This gotta be a firmware/driver issue. I tried the X11 and doesn’t even open the Desktop after login.