Fedora installer not working

Hi. I’m trying to install Fedora on my notebook but I’m not able to. I can create the Fedora usb drive, the system starts but when I click to open the installer, it doesn’t open. I’ve tried it with Fedora versions 33, 34 and 35 and it’s the same thing. I tried to start Anaconda from Terminal and the screen changed to the login screen and then the terminal showed the following:

liveuser@localhost-live ~]$ sudo anaconda
Starting installer, one moment…
anaconda 35.22.2-3.fc35 for anaconda bluesky (pre-release) started.

* installation log files are stored in /tmp during the installation
* shell is available on TTY2 and in second TMUX pane (ctrl+b, then press 2)
* when reporting a bug add logs from /tmp as separate text/plain attachments
11:13:52 Not asking for VNC because we don’t have a network
Traceback (most recent call last):
File “/usr/sbin/anaconda”, line 506, in
File “/usr/lib64/python3.10/site-packages/pyanaconda/ui/lib/storage.py”, line 388, in ignore_oemdrv_disks
matched = device_matches(“LABEL=OEMDRV”, disks_only=True)
File “/usr/lib64/python3.10/site-packages/pyanaconda/core/storage.py”, line 180, in device_matches
single_spec_matches = udev.resolve_glob(full_spec)
File “/usr/lib/python3.10/site-packages/blivet/udev.py”, line 163, in resolve_glob
for dev in get_devices():
File “/usr/lib/python3.10/site-packages/blivet/udev.py”, line 81, in get_devices
dev = device_to_dict(device)
File “/usr/lib/python3.10/site-packages/blivet/udev.py”, line 53, in device_to_dict
result = dict(device.properties)
File “/usr/lib/python3.10/site-packages/pyudev/device/_device.py”, line 1068, in **getitem**
return ensure_unicode_string(value)
File “/usr/lib/python3.10/site-packages/pyudev/_util.py”, line 64, in ensure_unicode_string
value = value.decode(sys.getfilesystemencoding())
UnicodeDecodeError: ‘utf-8’ codec can’t decode byte 0xf6 in position 4: invalid start byte

After this message, the installer did not work.

Below is the link to my Hardware report made with AIDA64.

AIDA64 Report

Thank you very much

EOL releases. Please open new topic if problem persists.