Fedora hangs on boot after upgrading to kernel 6.3.4

3 posts were split to a new topic: Fedora enters emergency mode with all kernels after 6.2.14-300.fc38.x86_64

@py0xc3 I just added the output of dmesg to the bug report as an attached text file since the template didn’t ask me for it originally. Hopefully this will help the issue get resolved! Please let me know if there are any other logs/reports I should attach to the bug report. Thanks!

It’s strange. Today when I turned on my laptop, it’s running on the latest kernel. The laptop working until second reboot. Now again, I can working only on kernel in version 6.2.15 and lower.

If I good remember yesterday evening, I was check some options in the BIOS.

Bellow is my link to boot-log on lastest version.

@glwwick Glad you are now able to boot a current Fedora kernel.

This does mean your issue was not the same as the one in this thread. Small details can be important to understanding problems with linux.

Now that you can boot, your adventure may continue with power management and sound issues.
If you need more help, please start a new thread and provide enough detail to allow others to reproduce the problem. Please include, in searchable text format using the </> button, the output of inxi -Fzx for your system.

That should be fine for now. I know you haven’t been asked. I saw that issue in multiple kernel bug reports and this is why I checked it and saw myself that there is currently no template at all. But the team is informed, so I assume the kernel bug report template is repaired soon.

Just keep watching the bug report and provide requested information if someone asks you there.


Is that the log of the one 6.3.6 boot that worked? Or is that a 6.3.6 boot that was broken?

My ASUS Vivobook S 14 Laptop (CPU: i5-12500H, GPU: Iris Xe, no dedicated graphics) is unbootable after upgrading to kernel 6.3.4 and above. But when I plug something into one of the usbc ports before turning on my laptop, kernel 6.3.5, 6.3.6 and 6.3.7(installed from bodhi) can boot without issue.

After unplugging everything from the usbc ports, I added module_blacklist=ucsi_acpi to grub kernel command line and successfully boot with kernel 6.3.6 and 6.3.7 .

I guess @glewik and @squidward also use Vivobook S laptop. Blacklisting kernel module ucsi_acpi may solve the problem for you.

It’s look like works. Thank you @fives . I’m wondering how will be look energy consumption now, and where did you find this solution?

Seems you found the bug. Thanks for letting us know!

I suggest to mention in the bug report if and for whom module_blacklist=ucsi_acpi solves the issue.

Also, if the blacklisting solves the issue for you, I suggest to add your dmesg output along with the information (please add the file or a link, do not paste the content as comment!).

It is possible that developers will ask you for more information to identifying the bug.


Just a side note, but I suggest all to try once 6.3.7 when it is released without blacklisting. Just to ensure that it remains necessary to keep the blacklisting (the same for future kernels).

Finally, this should not be a long term solution.

Thank you @fives ! I have the same laptop. The solution also worked for me. Kernel 6.3.6-100. Before the event (module_blacklist=ucsi_acpi) the only working boot was with kernel 6.2.15-200.

The dmesg output has cze 10 05:55:36 asus kernel: ucsi_acpi USBC000:00: PPM init failed (-110). ACPI is a cross-platform standard (despite Bill Gate’s efforts to make it Windows only!). Searching for ucsi_acpi PPM init failed (-110) will reveal many instances of problems with ucsi_apci in multiple linux distros.

Disabling, the module may be a quick workaround if you don’t use USB-C. Some reports say the problem is fixed with updates or after removing all power (not always possible for laptops).

I’ve got the same problem since kernel 6.2.15-300 or newer: when booting, my Thinkpad L590 (Intel UHD onboard graphics) stucks with “Booting a command list”

even module_blacklist=ucsi_acpi won’t help, BUT: acpi=off helps, but that’s not the way I’d like to work with the laptop

after booting with “pci=noacpi”, at least, the laptop boots for eight seconds and stops with

ucsi_acpi USBC000:00 PPM init failed (-110)

has anybody an idea, how to narrow this down?

is a very common error and has affected many distros over recent years. Are you using a USBC to HDMI monitor cable or a dock with USBC connections? Do you dual boot with Windows?

Some users report that it goes away if they disconnect a dock with USBC ports to boot, and can then connect the dock. There are also reports that a BIOS or NVIDIA driver update fixed the issue.

Please open a new topic because this seems to be not the same, although relations are possible (different error output, already 6.2.X kernel affected, different mitigation, …). Feel free to link the two topics (which means if you open a new topic, mention this one with a link and elaborate the similarities - mentioning the link to this topic in your new topic will automatically also create a link from here to your topic).

just for the sake of completeness: no dock or monitor cable involved but I got a dualboot (windows) system indeed

update: latest BIOS update (1.32) from lenovo did the trick! I’m now able to boot regularly again

Update : i was able to boot 6.3.7 with no USB peripherals attached only. As soon as I tried booting with them attached, system refused to boot. I had to fall back to 6.2.15

I do have an asus laptop (i5 12500H, Iris Xe with no dgpu) as you mentioned.

As @py0xc3 suggests, start a new thread linked to this thread. Please include enough detail to allow others to reproduce the issue:

  • output of inxi -Fzx in searchable text format

  • please mention dual boot with Windows version?, any external devices connected to the laptop, anything in the card reader slot, whether you use the fingerprint reader, any other uncommon details.

  • Is windows fastboot disabled?

  • history: is F38 a fresh Workstation install or upgrade or ?

You can look at LHWDB Lenovo Thinkpad L590 entries to see what issues others encounter.

1 Like

My laptop won’t boot 6.3.x with either the USB A wireless mouse dongle or the USB C charger plugged, but will boot ok without any USB device plugged. Blacklisting ucsi_acpi also solves the problem.

Asus Vivobook S 14X, Core i7 12700H, Iris Xe only.

So where are we tracking this bug? (the Asus laptop + USB one, not the one related to Nvidia cards).

Hey Ernesto,
I have the exact same Hardware (Asus Vivobook S14X with i7-12700h and Iris Xe Graphics only). The device will boot fine in kernel version 6.2.15, but will not boot with 6.3.x (6.3.7 does not work AS well) no matter if no USB device is connected or with a USB-C Hub connected.
I am wondering why we are seeing different behavior although we are using the same HW.

Anyway I think I will stick with 6.2.15 for now until there is a permanent fix available.

sorry for the answer here once again, but updating the BIOS to the latest available version fixed the issue for me