Fedora hangs during booting after the last update



Previous core versions have not helped.
Rescue hasn’t helped neither.
What was in the last upadte I don’t know. Something from an automatic update.
It hangs at the point at the log showed. Only Ctrl+Alt+Del works.

I figured out the solution. Just in case it helps somebody I will write the algorithm.

First, I added 3 to GRUB line just after quiet. It helped to get into command line at the end of booting process.
Then, I ran journalctl -b -1 and I noticed a ton of errors:
fedora rsyslogd[1039]: imjournal: rename() failed for new path: '/var/lib/rsyslog/imjournal.state': Permission denied. The later the more errors per seconds.
To figure out what wrong with the file I wrote:
sudo ls -lZ /var/lib/rsyslog/
and it turned out that there were two files
imjournal.state and imjournal.state.tmp
imjournal.state.tmp had syslogd_var_lib_t property and I left it alone.
Then I renamed imjournal.state to imjournal.state.ren
And immediately rsyslog renamed tmp version to original and the problem was solved.