Fedora freezes on clean install

I have a clean install of Fedora 31 but it randomly freezes after 1 to 20 minutes. I can’t even move the mouse when this happens. On every startup it says
We’re sorry, it looks like BOOT_IMAGE=(hd0,gpt2)/-
vmlinuz-5.3.7-301.fc31.x86_64 crashed. Please contact the
developer if you want to report the issue.
And when I click the problem reporting menu, I see a lot of System Failure messages from “xorg-x11-drv-nouveau” but it says the backtrace does not contain enough meaningful function frames to be reported.

I have a ThinkPad P1 Gen 2, which has 2 GPU’s (one of which is from nvidia).

My laptop has now become useless and I’m thinking about switching to another distro if that may help?

Hi @maarten0912

Sorry about your experience. Some days are like that in open-source world. I assume that you have not been able to run an update since this is happening on a fresh installation. Your issue may have been fixed in an update. So here is what you can do. You can bootup your system to a non-graphical environment. After that, login via the terminal and run a full update. Reboot and see if that solves the problem.

To boot to a non-graphical environment, press “E” once the GRUB Menu shows up. That will allow you to edit the boot parameters. Scroll down to the line that starts with “linux(with your arrow-keys). Go to the end of that line and add " 3" (with a space in front). Hit CTRL+X to boot with your modified GRUB configuration.

When you get to the terminal login screen, type your username and supply your password. After a successful login, do the following:

Use nmcli to connect to the internet if you are not already connected.

sudo dnf -y update

1 Like

After doing that, the given error message still appeared but also a notification saying “FailedToUpdate: Error calling StartServiceByName for org.freedesktop.fwupd: Timeout was reached”. However, it hasn’t frozen in over an hour so I think it worked! Thanks you so much

If you are certain that the freezing has stopped, then mark the post that solved it. However, we’d like to know more about that error. Perhaps you can open a new thread (present that as a new question) so we can get a better understanding of that issue.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.