Fedora forgets my default bluetooth input device when it disconnects

When I connect my bluetooth headset, the system automatically sets it as the default output device. However, it doesn’t set it as the default INPUT device. So every time I connect my headset I have to open Sounds > Input > and select my headset in the Device list. Having many meetings a day, this is a step I have to do before each meeting and it’s very error prone as I often forget.

Is there a way to make the system automatically set the headset as the input device as soon as I connect it? Meanwhile I will pursue running a loop on a script to try and set the device as default input when connected.

I am not sure if this will help, but I had the same problem at work on a windowz pc with Jabber. I had to go into the advanced audio settings of the application and set the priority order for the audio devices, so the headset was first.