Fedora for WSL can no longer download for DNF

Apologies if this is either tangential or already covered…

I’ve been using the Fedora “remix” for the Windows Subsystem for Linux, and have been pretty happy with it. I was using RHEL for work, so Fedora was a least-relearning choice.

Unfortunately that was based on Fedora 35, and dnf now tells me

Errors during downloading metadata for repository 'copr:copr.fedorainfracloud.org:wslutilities:wslu':
  - Status code: 404 for https://download.copr.fedorainfracloud.org/results/wslutilities/wslu/fedora-35-x86_64/repodata/repomd.xml (IP:
Error: Failed to download metadata for repo 'copr:copr.fedorainfracloud.org:wslutilities:wslu': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried

As I Understand It, this remix is not an official Fedora effort, and I probably should be finding and pestering the folks who created it (which I think is whitewaterfoundry). But I wanted to toss a query out here, in case someone else is running the WSL-wrapped Fedora and has already solved the problem… and because other folks may look here for answers.

Possible answer: the instructions at How to Upgrade to Fedora 37 In Place on Windows Subsystem for Linux (WSL) - DEV Community (after backing up, of course!). They haven’t blown up in my face yet…

You can deactivate the repository it and when you upgraded to a version who is not EOL (End of Live) you can include it again:

wslutilities/wslu Copr