Fedora doesn't go past started gnome point after modifying the x server settings

Hey I am new to fedora, but I have some experience in Ubuntu.

I have installed fedora yesterday, everything was going fine until I tried to change the resolution of the monitor (nouveau), and it pumped out an error (Badvalue)

So I downloaded the nvidia drivers to try and fix it, it went horrible, only two 16:9 resolutions were available and the screen was awfully zoomed and I couldn’t see anything.

After some research I acknowledged that the dvi converter I’m using was blocking the EDID from the monitor,
So what I did was creating a custom EDID, by extracting the already existing one from windows 10, and moving it over and using it, as per the instructions provided by the arch wiki.

-NVIDIA/Troubleshooting - ArchWiki

-Kernel mode setting - ArchWiki

I created the .EDID file and moved it to fedora and made a .conf in the X11 directory.

Here is the problem, whenever I modify the x server settings, the fedora will never get past the point of a CLI with the last line in it being :Started gnome display manager.

It never goes past this point and if I try going to the console by pressing Ctrl+Alt+F3 and typing gdm as root,
Nothing happens except a black screen after going back to the GUI interface.

Please help I’m so frustrated by this problem, as it also happened in Ubuntu, but I seemed to get around it by deleting the xorg.conf file, but I didn’t get the desired resolution, so I just decided to stay in a smaller res.

I decided to switch to fedora in order to learn more about linux and avoid the frankendistro I made using Ubuntu.

Thank you.

   Hi @gasmask.  The Fedora with Gnome uses Wayland by default (with the libre nouveau driver, at least): so you shouldn’t use X-server settings (with the Nvidia’ p-driver rhather should).
   Try to delete or blacklist the nvidia driver, and see if the box boots in the graphics with nouveau, then try to use the GUI settings to set up the screen resolution.


Just by the way, Wayland works much better, even on my old Desktop. Only AMD APU and Radeon graphics card, lovely on Fedora Workstation.


Well, what i did and worked for me was deleting the nvidia drivers and installing nouveau once again, switching to wayland, and then forcing the kernel to a single resolution mode, it works now.
Thanks for the reply, appreciate your effort.
and sorry for being late, seems that the fedora mailing service is a bit too late

Yeah, I’ve always had trouble with X, wayland seems to be good at least for the moment.
Thanks for the reply


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.