Fedora doesn't boot

I installed the package CGAL-qt5-devel.x86_64 and after that I wasn’t able to launch any program so I tried running Alacritty from an already opened terminal session but I got an error about mesa version if I remember correctly. So I rebooted and this is where I am

The system only shows a blinking cursor after passing several stages of boot and I’m not able to type anything. Tried booting into older kernels but nothing changed.

Also removed that package in rescue mode but it didn’t help.

What should I do?

Hi! I think we need some more information in order to help you.

It is very abnormal that installing a -devel package would cause programs not to start. Do you remember anything out of the ordinary when you installed the package? What exactly did happen when you tried to launch a program?

Can you describe (or screen shot, at least?) the stages of boot that go past?

And, it seems that rescue mode works? Can you check the system logs for errors, both at boot time and around the time you installed the package?

Not really, but I had to stop downloading to turn off VPN

I didn’t pay enough attention to the output and I don’t record them, but it was warning and had somthing like [mesa 23.xx vs mesa 21.xx] at the end :no_mouth:

Starting GDM, and everything was OK nothing Failed

Unfortunately I’m not familiar with needed logs, so I don’t know what should I look for.

As I check for error keyword at /var/log/boot.log via grep there are nothing.

Hello @naadiyaar ,
It would be better to use journalctl -b to get the last journal entry of the boot. See man journalctl for greater details on using it. You can go backward in boots using -1, -2, -3, etc… to get to the previous boots.

1 Like

Although I couldn’t find out what exactly was broken that caused this issue, I think the reason was installing CGAL-qt5-devel.x86_64 made DNF to Downgrade mesa-libEGL-23.0.1-2.fc38.x86_64 and started all the problem.

I followed Telegram: Contact @Wolfshappen advice and ran dnf distro-sync --best --allowerasing --refresh in chroot and now system boots successfully again.

1 Like