Fedora CPU issue

Hey, I recently bought a powerful PC for music production and installed Fedora on it.
Everything works fine but I feel like the CPU performance is much worse than what I would expect.
I did a test where I ran the exact same music production session on both my old macbook running macOS with a 2 core intel i5 from 2015 and on my new Fedora PC with intel 10th Gen 8-Core i7 10700T.
On my old macbook the session uses up about 45% cpu, while on this new PC it uses about 35%… It is a bit better but I expected a much bigger improvement from this CPU.
I’m not very technically experienced so I’m looking for tips on how to diagnose what’s wrong and find a solution.


Hi, there. :thinking: If the newer PC only uses 35% and the old one use 45% when running the same app, my interpretation is the new PC are more powerful since it only need 35% from the cpu resources.

May be you can test with same app and create same project that have lot of audio layers then export it. Compare the time needed between them to complete the export.

hey, thanks for answering. The new pc is indeed a bit better but I would expect a more drastic difference between a 7 year old 2-core i5 cpu and a fairly recent 8 core i7 cpu. My expectation was the the new pc would use drastically less than the old one.

May be if you use Gnome (Fedora Workstation), you could check Gnome Settings → Power. If the options for Performance available, may be you could try it.

How are you checking the percentages? Could macOS be saying 45% of total CPU power (scale would be 0-100%), whereas Fedora is reporting 35% of single core (scale would be 0-1600% for 8 core/16 thread CPU)?

To check the percentages I’m using System Monitor on Fedora and the equivalent (forgot the exact name) on the macbook.

I think I found what’s the main issue - seems to be something with the audio driver. By changing it from ALSA to PulseAudio my cpu load dropped from 35% to about 20% on the Fedora machine.
I will now also try the Settings > Power option as suggested, might give me and additional imperovement.
I think this is now mostly solved : )
Thanks for the help!

1 Like