Fedora booting to a black screen unless I boot with "nomodesetting" on AMD drivers

So, I rebooted the system without any update and went to Windows (unfortunately the only way to play Apex Legends), after rebooting again on Fedora it wasn’t booting unless I disable the AMD driver using “nomodesetting” (blacklisting amdgpu doesn’t work). I tried restoring the system with Timeshift to 2 days ago and it didn’t work (same problem). What can I do?
My system is an Intel Core i5 9400F, 16GB of RAM and a Vega 56 GPU.

PS: it happened (probably) the same thing some weeks ago and it boot again normally the other day (I kept using just Windows), and there was one thing in common that I did: I booted why my old home theatre (that wasn’t being used) turned on. It is connected to the computer with 3 P2 to RCA stereo jacks for 5.1 audio (I use ALSA hdajackretask for it) while the computer speakers are connected to the monitor (HDMI sound). I don’t know how this could be related but it is the only thing I can think of. I already tried to boot with the audio cables unplugged with no success.

Hello @pedrofleck, and welcome to the forum.
To try to diagnose the issue, you could look at the output of the boot log using journalctl -b. Looking through it may point to the issue for you.

Please, make sure that your card isn’t uses the radeon driver (new ones should use amdgpu):

Just tried it. Unfortunately it didn’t work.

I tried it but it just shows the last boot, right? And I can’t boot without nomodesetting (not even to shell).

man7.org: man 1 journalctl

# -1 will be before-last
journalctl -b -0

-p , –priority=

  • “emerg” (0), “alert” (1), “crit” (2), “err” (3), “warning” (4), “notice” (5), “info” (6), “debug” (7)
1 Like

So: Your blocked driver named radeon, tried to boot with driver named amdgpu. And it is fail too?

So if you do use nomodeset you can boot without any problem? if it is so maybe you can try the following: you do have a intel CPU without GPU so it is not one hybrid CPU like others but maybe the kernel is trying loading the module i915 as graphic driver in anyway, you can check disabling it setting in the boot parameter i915.modeset=0 if you can boot after…possibly it was the cause. and you will only need set the parameter permanently and if it is the case also report a bug against kernel. If it doesn’t you should look at your journalctl like indicate in the previous comments and also check your settings of secureboot (enable,disable), fastboot (if on or off),… and check around your installation too.


You can list all boots with it as well using journalctl --list-boots then select the boot ID of interest and use journalctl -b [ID] to look at the offending one. Or if you know it was x boots previous you can use journalctl -b [-x] (x representing the number of boots previous). There is also a pretty good Fedora Magazine article here that explains journalctl better than I.

1 Like

Ok, I’m feeling that I’m the dumbest person alive right now (specially because I had to use Windows all of these days), but the fix to the problem was to remove and put again the HDMI cable during the black screen. I don’t know what caused it since GRUB and booting with ‘nomodeset’ showed up just fine, but I just removed the cable, put it back and tada: GDM login screen. Thanks for your help, at least I learned how to better use journalctl.

Do your need to put the cable in and out every time?

No, it’s just working now. I don’t know what caused it. What caught my attention to do it was that I couldn’t even see the boot process when removing the “quiet” parameter in GRUB.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.