Fedora Asahi Remix boot into black screen after installation

I am using MacBook Pro M1 Pro with Mac OS version 14.3, I have tried to solve this issue by installing different version each time, but every time I t boot into black screen, I have tried fedora 38 gnome, Kde plasma and minimal and the same for fedora 39, and even I have tried Ubuntu Asahi and it also has failed , I hope there is a solution for it.

I believe the macbook uses an nvidia gpu.
When booting from the install media for fedora you may need to select the troubleshooting option then boot with basic graphics. Apparently some nvidia gpus are not supported properly by the default nouveau driver so initial boot must be done in basic graphics mode.

If this is after the initial install completes then you should (from the grub menu) press the e and edit the line that begins with linux. Add the option nomodeset into that line then continue booting.

The final fix is usually to enable the 3rd party repos during the initial setup then install the nvidia drivers with sudo dnf install akmod-nvidia from a terminal. Wait about 5 minutes after the installation completes then reboot and it should boot properly now.

From Ask Fedora to Ask Asahi

Added nvidia and removed f38, f39, gnome, kde, kde-plasma

I have followed your instruction, it is not working, it says boot list of commands, and nothing happen.

No Apple Silicon computers use Nvidia GPUs (or AMD GPUs). They use Apple Silicon GPUs.

It is not possible to use NVIDIA GPUs on Apple Silicon Macs.

My bad!
I did not realize the post was not about an intel MAC. Ignore what I posted above.

@computersavvy Thank you for suggestion, nomodeset has worked for me, but the apple m1 pro gpu is not working only software rendering, I have tried to make the gpu works, but no luck finding a solution so far.

On other hand while I was searching for a solution, I stumbled upon the rescue mode, I tried it and got this message
“apple dcp failed to get dcp-xbar”, when the system booted without adding nomodeset to grub.

The good news is the external monitor which is plugged in using hdmi was working, as well the Apple M1 Pro (G135 CO) gpu, except the built in display still not working.

the summary of the issue:

when nomodeset is enabled:

  • built in display and externel monitor is going work.
  • apple m1 pro gpu is not going to be disabled and the system is going to use software rendering instead.

when the system boot without nomodeset:

  • apple m1 pro gpu and the external will work fine.
  • the built in display is going going to be black.

here is a ling for the boot log file:
boot log

I hope there is a solution for it.

I have solved this issue by downgrading to Mac OS 13.6 using DFU mode, I am not an expert to say the real cause of this problem but I believe there is a firmware issue in Mac OS Sonoma that cause the screen to be black.