Fedora - Are there any drivers for USB dongle TP-LINK WN823N RTL8192EU V3?

Did you update system?“Package kernel-devel-5.1.5-300.fc30.x86_64 is already installed” is package for new kernel.You must reboot and match kernel with kernel-development package

1 Like

It’s my error - again. Sorry; I entered dnf install update instead of dnf install upgrade and I haven’t been scrutinous with the output. The system is now upgrading. I’ll keep you posted.

Oh, that’s not right neither, for now I’m downloading Fedora 30 entirely, right?

No but downloads and update system look like it is 800+ mb

1 Like

Ok, progress. I upgraded (dnf upgrade) and rebooted, but got the same error message above. On repeat of the list above I rebooted before the make command. This time I got past that particular error. Does this mean that I successfully matched the newly installed kernel-devel with the kernel-development package?

Now my latest error report is this;

[root@localhost RTL8192EU]# make install
install -p -m 644 8192eu.ko /lib/modules/5.1.5-300.fc30.x86_64/kernel/drivers/net/wireless/
/sbin/depmod -a 5.1.5-300.fc30.x86_64
depmod: ERROR: failed to load symbols from /lib/modules/5.1.5-300.fc30.x86_64/kernel/drivers/target/iscsi/iscsi_target_mod.ko.xz: Input/output error
[root@localhost RTL8192EU]#

Sorry, i don’t know about this error nothing .Maybe someone will know about this more. Check you have kernel-modules-extra & kernel-modules packages installed. Just run dnf install kernel-modules-extra kernel-modules

Check; these are already install.

I understood from @bluebat’s post that the old driver (what I now know to be rtl8xxxu) would be blacklisted automatically. Today I followed leesei’s instructions found here (last post)^ and rebooted. I then retried @bluebat’s instructions again. This time there was much more output but the automation still aborted at the bad exit of a tmp file. I then tried ZeeRooo’s instructions again and this time the installation completed.

^I already installed the driver, but I can not connect to a wifi network · Issue #46 · Mange/rtl8192eu-linux-driver · GitHub

I rebooted but, alas, still no wireless for the dongle, but I am getting system crashes pertaining to the 8192eu driver:

I then go to enter sudo su lshw -c network and see, to my surprise, that rtl8xxxu has actually loaded:

[root@localhost useru]# lshw -c network
       description: Wireless interface
       physical id: 1
       bus info: usb@2:1.3
       logical name: wlp0s29u1u3
       serial: a2:37:bd:38:20:d8
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=rtl8xxxu driverversion=5.1.5-300.fc30.x86_64 firmware=N/A link=no multicast=yes wireless=IEEE 802.11

I’ve checked to see whether the blasklist file is there, and it is:

But one other thing that I did (and I now wish that I had done them deperately) was to remove the dongle before retrying the relevent instructions mentioned.

I am reckoning that I now have a conflict.

@ledeni Success! I remembered what you’d shown me:

rmmod rtl8xxxu
modprobe 8192eu

Resolved! I suspect though, that on reboot the persistent rtl8xxxu will load. I’ll let you know.
Have yourself a good weekend.

And it did, and now I see my error: my blacklist file ends with ,conf (note the comma) instead of .conf

Now the rtl8xxxu is blacklisted. So it appears that ZeeRooo’s driver (above) loads once the rtl8xxxu driver is blacklisted (I already installed the driver, but I can not connect to a wifi network · Issue #46 · Mange/rtl8192eu-linux-driver · GitHub), or because the dongle is unplugged while loading the driver.

Hello, I can’t install the driver on Fedora 30, I have kernel-devel package installed, I cloned RTL8192EU’s repo, but when I try “sudo modprobe 8192eu” I get the following error :

“modprobe: ERROR: could not insert ‘8192eu’: Operation not permitted”

Any clue ?

@icecube try disable secureboot from UEFI.

Hello @youssefmsourani, thanks for the advice, I disabled secureboot and the command worked !

But it seems that the driver is still not working, when i plug the dongle i have the following system error :


I did blacklist rtl8xxxu and rebooted but it changes nothing :cry:

Any ideas ?

i dont know but try this .

echo blacklist rtl8xxxu |sudo tee /etc/modprobe.d/rtl8xxxu_blacklist.conf

sudo dracut --regenerate-all --force -v

dracut will regenerate all initramfs ,don’t turn off your computer during dracut is running .

This image just to shows that the file required to become inside initramfs , maybe this help.

I’m not sure it will work.

Don’t forget to read the comments here https://github.com/Mange/rtl8192eu-linux-driver/issues/46

Hello @youssefmsourani, unfortunately it didn’t help. I see no wifi driver with lshw -c network, only ethernet. And I still encounter system errors when i plug my dongle.

I think those drivers aren’t supposed to work yet with kernel 5.3.6, I think i’m going to give up, maybe someone will find a solution in the future. Thank you for your help

1 Like

:vertical_traffic_light: I’ve got a better approach for this :clap:

I’m on :fedora: 32 Kernel Version 5.6…

I’ve had also this product, I bought it yesterday, after a large investigation because the product box said full LINUX support :frowning: : I’ve found this GITHUB, updated to the latest kernel 5.6:

Just, git clone the repo and type:


Reboot and voila :100: :partying_face:


with dkms support for rebuild on each kernel update…


But what is the difference with this other one repository?

The Big diferencie is error compiling in latest kernel


sir, what commands should i use to update it’s driver?
would you like to list it?

You are posting on a thread that has been necro for about 3 years. Fedora has had about 6 version releases in that time and what was appropriate and worked then likely will not work now.

Please open your own thread for any issues you have for a current fedora release. I am closing this thread.