Fedora 40 Workstation Prerelease: VRR setting not available after gsettings command?

Yesterday, I installed Fedora 40 Workstation Prerelease with Gnome 46 RC. I tried the command
gsettings set org.gnome.mutter experimental-features "['variable-refresh-rate']" (GNOME 46 to Ship with Experimental Variable Refresh Rate (VRR) Support - 9to5Linux), but after rebooting, the VRR setting is still not available.

grafik

I remember testing the Prerelease some days ago and I got the setting.

Any idea what could be the reason? Did the command change in RC version?

Here are my PC specs:

System:
  Kernel: 6.8.0-0.rc6.49.fc40.x86_64 arch: x86_64 bits: 64
  Desktop: GNOME v: 46.rc Distro: Fedora Linux 40 (Workstation Edition
    Prerelease)
Machine:
  Type: Desktop Mobo: Micro-Star model: MAG X570 TOMAHAWK WIFI (MS-7C84)
    v: 1.0 serial: <superuser required> UEFI: American Megatrends LLC. v: 1.F0
    date: 10/12/2023
CPU:
  Info: 12-core model: AMD Ryzen 9 3900X bits: 64 type: MT MCP cache:
    L2: 6 MiB
  Speed (MHz): avg: 2216 min/max: 2200/4672 cores: 1: 2200 2: 2200 3: 2200
    4: 2200 5: 2200 6: 2200 7: 2200 8: 2589 9: 2200 10: 2200 11: 2200 12: 2200
    13: 2200 14: 2200 15: 2200 16: 2200 17: 2200 18: 2200 19: 2200 20: 2200
    21: 2200 22: 2200 23: 2200 24: 2199
Graphics:
  Device-1: AMD Navi 32 [Radeon RX 7700 XT / 7800 XT] driver: amdgpu v: kernel
  Display: wayland server: X.Org v: 23.2.4 with: Xwayland v: 23.2.4
    compositor: gnome-shell driver: dri: radeonsi gpu: amdgpu
    resolution: 3440x1440~144Hz
  API: OpenGL v: 4.6 vendor: amd mesa v: 24.0.0 renderer: AMD Radeon RX
    7800 XT (radeonsi navi32 LLVM 17.0.6 DRM 3.57 6.8.0-0.rc6.49.fc40.x86_64)
  API: EGL Message: EGL data requires eglinfo. Check --recommends.
Audio:
  Device-1: AMD Navi 31 HDMI/DP Audio driver: snd_hda_intel
  Device-2: AMD Starship/Matisse HD Audio driver: snd_hda_intel
  API: ALSA v: k6.8.0-0.rc6.49.fc40.x86_64 status: kernel-api
  Server-1: PipeWire v: 1.0.3 status: active
Network:
  Device-1: Realtek RTL8125 2.5GbE driver: r8169
  IF: enp38s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth:
  Device-1: Intel AX200 Bluetooth driver: btusb type: USB
  Report: btmgmt ID: hci0 state: up address: <filter> bt-v: 5.2
Drives:
  Local Storage: total: 7.51 TiB used: 2.9 TiB (38.6%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 970 EVO 1TB size: 931.51 GiB
  ID-2: /dev/nvme1n1 vendor: Samsung model: SSD 970 EVO Plus 2TB
    size: 1.82 TiB
  ID-3: /dev/sda vendor: Samsung model: SSD 850 EVO 1TB size: 931.51 GiB
  ID-4: /dev/sdb vendor: Western Digital model: WD20EZBX-00AYRA0
    size: 1.82 TiB
  ID-5: /dev/sdc vendor: Western Digital model: WD20EZBX-00AYRA0
    size: 1.82 TiB
  ID-6: /dev/sdd vendor: Samsung model: SSD 850 PRO 256GB size: 238.47 GiB
Partition:
  ID-1: / size: 921.93 GiB used: 9.43 GiB (1.0%) fs: btrfs dev: /dev/nvme0n1p4
  ID-2: /boot size: 973.4 MiB used: 251.3 MiB (25.8%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-3: /boot/efi size: 598.8 MiB used: 19 MiB (3.2%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-4: /home size: 921.93 GiB used: 9.43 GiB (1.0%) fs: btrfs
    dev: /dev/nvme0n1p4
Swap:
  ID-1: swap-1 type: partition size: 8 GiB used: 0 KiB (0.0%)
    dev: /dev/nvme0n1p3
  ID-2: swap-2 type: zram size: 8 GiB used: 0 KiB (0.0%) dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 37.8 C mobo: N/A gpu: amdgpu temp: 36.0 C
  Fan Speeds (rpm): N/A gpu: amdgpu fan: 0
Info:
  Memory: total: 32 GiB available: 31.26 GiB used: 5.74 GiB (18.3%)
  Processes: 684 Uptime: 4h 29m Shell: Bash inxi: 3.3.33

It’s just not available yet. These changes landed upstream basically a week ago. Wait a bit. :wink:

1 Like

Thanks, @catanzaro ! :slight_smile:

But I’m a bit confused now. I am 99.99999% sure that I saw this setting during my installation 3 days ago … :thinking:

So I’ll wait a bit. How can I be sure that this feature is available then?

You can’t.
However your interest and experiences would be best if posted to the testing mailing list so the developers know what you see, problems that may be encountered, and what may been resolved.

Using a new release while it is still in the pre-release stage seems to imply that you are testing it, and as such your experiences would definitely be of interest to the testing team.

Unfortunately I do not have the link to guide you but maybe @augenauf or someone else may be able to provide that.

1 Like

Getting the link would be great! :+1:

The VRR changes are included in mutter 46.rc and gnome-control-center 46.rc.

  • mutter 46.rc is currently in updates-testing, so it’s available, but also probably too late for F40 beta.
  • gnome-control-center 46.rc is not built yet at all, so not available yet.

I would expect it to appear sometime soon, certainly before F40 final release.

If you’re impatient, feel free to submit a merge request to the gnome-control-center package. It’s probably a simple update.

1 Like

Actually it looks like the packaging has already been updated, and it’s even built successfully, but hasn’t been submitted to updates-testing yet. I guess the update is probably being queued up in a side tag, to be submitted soon?

1 Like

Actually, there is an update here that was just submitted an hour ago. Should be available in updates-testing shortly.

1 Like

Sounds great. So I don’t have to do anything, just wait for the update? Am I right?

Yes, though I would check to make sure you have updates-testing is enabled. I would expect that you do. It will probably take a long time to move from updates-testing to stable due to the beta freeze.

1 Like

Yes, I have.

grafik

Ok. But I’m on the safe side with enabled updates-testing. Thanks a lot for helping, @catanzaro ! :+1:

Just got that update and now VRR setting is available. :slight_smile:

grafik

Thanks again! :+1: