Fedora 40/Rawhide immediately wakes up after suspend

I’ve tried Ubuntu 24.04 LTS, Fedora 40 Workstation, and Fedora Rawhide and, on all of these, the system suspends but doesn’t stays suspended, waking up almost immediately.

Currently I’m running Bluefin (Fedora spin off). The problem also persists here.

The log for the suspend operation shows the CPU wakes up immediately.


[  837.528133] PM: suspend entry (deep)
[  837.680181] Filesystems sync: 0.152 seconds
[  837.684332] Freezing user space processes
[  837.687530] Freezing user space processes completed (elapsed 0.003 seconds)
[  837.687534] OOM killer disabled.
[  837.687535] Freezing remaining freezable tasks
[  837.688551] Freezing remaining freezable tasks completed (elapsed 0.001 seconds)
[  837.688565] printk: Suspending console(s) (use no_console_suspend to debug)
[  839.120045] r8169 0000:03:00.0 enp3s0: Link is Down
[  839.126391] sd 4:0:0:0: [sdd] Synchronizing SCSI cache
[  839.126426] sd 3:0:0:0: [sdc] Synchronizing SCSI cache
[  839.126447] sd 1:0:0:0: [sdb] Synchronizing SCSI cache
[  839.126467] sd 0:0:0:0: [sda] Synchronizing SCSI cache
[  839.127076] ata4.00: Entering standby power mode
[  839.127095] ata5.00: Entering standby power mode
[  839.127234] ata1.00: Entering standby power mode
[  839.127241] ata2.00: Entering standby power mode
[  840.156356] PM: suspend devices took 2.468 seconds
[  840.157400] ACPI: EC: interrupt blocked
[  840.169493] amdgpu 0000:01:00.0: amdgpu: PCI CONFIG reset
[  840.181944] ACPI: PM: Preparing to enter system sleep state S3
[  840.182455] ACPI: EC: event blocked
[  840.182458] ACPI: EC: EC stopped
[  840.182459] ACPI: PM: Saving platform NVS memory
[  840.182563] Disabling non-boot CPUs ...
[  840.184310] smpboot: CPU 1 is now offline
[  840.186882] smpboot: CPU 2 is now offline
[  840.189514] smpboot: CPU 3 is now offline
[  840.191745] ACPI: PM: Low-level resume complete
[  840.191762] ACPI: EC: EC started
[  840.191763] ACPI: PM: Restoring platform NVS memory
[  840.192083] Enabling non-boot CPUs ...
[  840.192131] smpboot: Booting Node 0 Processor 1 APIC 0x2
[  840.195848] CPU1 is up
[  840.195889] smpboot: Booting Node 0 Processor 2 APIC 0x4
[  840.199355] CPU2 is up
[  840.199393] smpboot: Booting Node 0 Processor 3 APIC 0x6
[  840.202937] CPU3 is up
[  840.205261] ACPI: PM: Waking up from system sleep state S3
[  840.205625] ACPI: EC: interrupt unblocked
[  840.207059] ACPI: EC: event unblocked
[  840.228427] [drm] PCIE gen 2 link speeds already enabled
[  840.229487] [drm] PCIE GART of 1024M enabled (table at 0x000000F400A00000).
[  840.232754] amdgpu 0000:01:00.0: amdgpu: SRBM_SOFT_RESET=0x00100040
[  840.327818] nvme nvme0: 8/0/0 default/read/poll queues
[  840.365588] r8169 0000:03:00.0 enp3s0: Link is Down
[  840.406356] [drm] UVD initialized successfully.
[  840.527375] [drm] VCE initialized successfully.
[  840.530478] ata3: SATA link down (SStatus 0 SControl 300)
[  840.530498] ata6: SATA link down (SStatus 0 SControl 300)
[  840.531242] PM: resume devices took 0.324 seconds
[  840.531460] OOM killer enabled.
[  840.531462] Restarting tasks ... done.
[  840.549589] random: crng reseeded on system resumption
[  840.566513] PM: suspend exit

Fixes that didn’t work

  • Killing NetworkManager process.
  • Disabling all devices in /proc/acpi/wakeup
  • Removing all USB devices, Bluetooth dongle, except from keyboard.
  • Disconnecting LAN cable.

As you can see, there are no errors on the log. An alternative should be to set a flag on the kernel to report to the ACPI as Microsoft Windows NT but beats me how to do it.

Nobody has this same problem?

You can ask Bluefin questions on their Discourse forums.

Are you a bot or a troll account? Did you read the first line?

Nope, i’m neither. I do understand the line that says you are currently on Bluefin.
So, if you are not currently on Fedora proper, how can we troubleshoot Fedora issues ?

Does that make sense?

Removed f40, fedora-rawhide, workstation

Logs are the same, to clarify.