Fedora 40 KDE - Boot animation not working properly

Hi everyone! I noticed that recently the boot animation on my Fedora system has disappeared - there is no brand logo, and the spinning circle with Fedora logo has been replaced with random three dots that don’t even appear on the center of the screen. The system boots normally, it just doesn’t show the animation - interestingly enough, it does show it at shutdown, just not at boot. The same dots also appear while installing updates.

How can I fix this? I tried these solutions:

  • Restoring Plymouth theme to default and regenerating needed files (sudo plymouth-set-default-theme bgrt & sudo dracut -f)
  • Resetting Plymouth to default (sudo plymouth-set-default-theme --reset)

And stil no luck. :frowning:

My system specs:

Operating System: Fedora Linux 40 KDE Plasma Version: 6.0.5 KDE Frameworks Version: 6.2.0 Qt Version: 6.7.0 Kernel Version: 6.8.10-300.fc40.x86_64 (64-bit) Graphics Platform: Wayland Processors: 4 × Intel® Core™ i3-6006U CPU @ 2.00GHz Memory: 7.7 GiB of RAM Graphics Processor: Mesa Intel® HD Graphics 520 Manufacturer: HP Product Name: HP Laptop 15-bs0xx System Version: Type1ProductConfigId

I’d be grateful for any help. :slight_smile:

This might help.

Source:

[ SOLVED ] Plymouth can't start SDDM? / [testing] Repo Forum / Arch Linux Forums

Sorry for the bad information, by the way, I’ve finally found the issue! It’s coming from SDDM, it hasn’t supported smooth transition yet!
To everyone using smooth transition with SDDM and having same issue like me, just do this

# systemctl revert sddm.service

Thanks for everyone who helped me.

Thank you, but sadly this doesn’t fix the issue - I just tried it, and still get the three dots on boot. :frowning:

I also don’t see the list of backup kernels to pick from.

I’m seeing the same on my laptop - grey screen, three white dots / small squares off-centred towards the top-left of the screen. And curiously it works as expected during shutdown.

Lenovo Legion 5, AMD Ryzen 7 5800H with Radeon Graphics, AMD ATI Radeon Vega Series / Radeon Vega Mobile Series, AMD ATI Radeon RX 6600/6600 XT/6600M.

Thank you for responding - I’ve seen several posts with this issue popping up over the years, but no proposed solutions seem to fix this problem. :frowning:

For me it started after the upgrade to fedora 40 - I did not observe this issue on fedora 39 or earlier. Has this been reported as a bug? Maybe you (or I) should report it.

Same here - On Fedora 39 boot up worked perfectly fine.

I found this bug report, but it has since been closed down because it concerned Fedora 38, which was EOL:

https://bugzilla.redhat.com/show_bug.cgi?id=2190471

As you can see, it received no responses except for the automatic ones. :frowning:

I filed a new bug report that will hopefully see some fresh input:

https://bugzilla.redhat.com/show_bug.cgi?id=2283839

I’ve added a comment to your bug report. Hopefully more people will post comments and we can get some eyes on this.

Sweet! Thank you for your help. :slight_smile:

1 Like

We got a new Plymouth update which might fix it.

===============================================================================
  plymouth-24.004.60-10.fc40
===============================================================================
  Update ID: FEDORA-2024-4c865b3461
       Type: bugfix
    Updated: 2024-05-29 05:45:17
       Bugs: 2270030 - Boot sometimes uses text mode plymouth even though plymouth-theme-spinner is installed and it should use graphical mode
Description: - Revert patch to immediately switch to text mode on first renderer plugin error (#2270030)
           : - This fixes plymouth sometimes showing the text splash on machines where the graphics splash works just fine
   Severity: None
2 Likes

The grub boot menu is hidden by default on fedora.
Check that with sudo grub2-editenv - list to see if there is an option menu_auto_hide=1 displayed.
If so then the menu is normally hidden but can be displayed with each boot by holding down the shift key during the boot after the bios screen appears.

If you wish to have the grub menu displayed with every boot remove that option wih grub2-editenv - unset menu_auto_hide

1 Like

That’s the version currently installed on my laptop - installed on the 29th of May (two days ago). Unfortunately it did not resolve the issue.

Sadly, this doesn’t fix the issue on my end :frowning: I installed the update, rebooted and three dots still persist.

Thank you for this information - very helpful!

I installed the update today, and re-checked just a moment ago - the issue still persists :frowning:

I had the issue on a Kinoite install. Today I installed the upgrade and the startup animation is as it should be.

Could you post plymouth version please?

Sadly, issue still persists on my install even after installing all available upgrades. :frowning:

24.004.60 on a net install

Deployments:
● fedora:fedora/40/x86_64/kinoite
                  Version: 40.20240604.0 (2024-06-04T01:12:51Z)
                   Commit: abe562413283cc176c91f5987d74a970b221a770d96ca53b2815bd5e2c0c3297

Maybe someone can tell me how I do check the version of an app in a atomic-de.
On a rpm based install I do dnf info

Update: switching to an earlier kernel version restores boot animation

Thanks to a helpful Reddit comment I tried switching back to an earlier kernel version. Results are as follow:

Kernel Version: 6.8.11-300.fc40.x86_64 (64-bit) - animation not working during boot - displays three dots instead of the Fedora logo. Works fine at shutdown.

Kernel Version: 6.8.10-300.fc40.x86_64 (64-bit) - same as above.

Kernel Version: 6.8.9-300.fc40.x86_64 (64-bit) - animation works properly during boot and shutdown - displays the Fedora logo and spinning circle correctly.

Could this be a kernel-related bug? Can I switch to Kernel version 6.8.9 and boot from it instead of 6.8.11?