Fedora 39 not booting: failed to start docker.service

Problem

Hi,

I was updating my Fedora 39 to kernel 6.8.5-200.fc39.x86_64, when during a restart it got interrupted due to low disk space (this is my assumption, which I figured out later)
After the restart, fedora never booted again, it would get stuck on the loading screen with the fedora icon in the bottom.
I tried booting into older kernel versions, but the same thing happens.

The only troubleshooting I was able to do is press ‘e’ on the kernel I want to boot to, then remove the “rhgb quiet” parameters to see the boot logs. Here is where it gets stuck:

[FAILED] Failed to start grafana-server service - Grafana instance.
[FAILED] Failed to start docker service - Docker Application Container Engine.

After adding the “rw init=/bin/bash” parameters, I was able to boot into what looks like shell mode with root user, I executed “df” to find that the main partition is 100% full, so I freed up some space. However I tried to uninstall Docker and Grafana and this is the output of any “dnf” or “rpm” commands:

error: sqlite failure: CREATE TABLE IF NOT EXISTS ‘Packages’ (hnum INTEGER PRIMARY KEY AUTOINCREMENT, blob BLOB NOT NULL): disk I/O error
error: cannot open Packages index using sqlite - No such file or directory (2)
error: cannot open Packages database in /usr/lib/sysimage/rpm

And now I don’t know where to take it from here. Any help is greatly appreciated!

From Proposed Common Issues to Ask Fedora

See if you can delete files without using dnf to uninstall packages.

I think you do not have enough of the system working to use dnf remove.

1 Like