Fedora 39 KDE & external monitor logout causes laptop to sleep

Hello there!

I recently bought a new laptop (Lenovo P14s Gen 4, AMD) and decided to go Linux “full-time”. I’m using the Fedora 39 KDE Spin and I’m really happy with the experience so far. Pretty much everything works out of the box. There is just one problem that’s bothering me: Whenever I use my laptop attached to an external screen (connected by USB-C, laptop screen closed) and I logout my user from the KDE session I don’t get presented the SDDM login screen but my notebook goes to sleep. To wake it up again (and login) I have to open the laptop screen. Am I missing some setting? When using just the notebook screen login/logout works as expected.

Any help would be greatly appreciated. Thanks!

SDDM seems to use KDE defaults for various things which cannot be changed, for example you cannot change the brightness etc.

My guess is that it uses the KDE Default settings, which is to go to sleep when closing the lid.

If you dont find a way to change this behavior to “turn off screen” or “do nothing”, you may just want to disable the lid sensor in your BIOS, which should be possible.

You can then inside KDE always chose to only use the external monitor, SDDM will be displayed on both but should not matter.


Now to find a real solution, this should work

systemctl edit systemd-logind.service

# add --ignorelidswitch do the ExecStart line

systemctl restart systemd-logind.service